2000 gt 3L Transmission interchange question - Club3G Forum : Mitsubishi Eclipse 3G Forums
Go Back   Club3G Forum : Mitsubishi Eclipse 3G Forums > Eclipse General Discussion > 3G Eclipse General Discussion
Club3G Decals

Club3G.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 04/23/2010, 10:50 PM   #1 (permalink)
Junior Member
 

Join Date: Apr 2010
Posts: 3
richid : who are you?
2000 gt 3L Transmission interchange question

I have 2000 gt v6 automatic. Bought it for my girl. The transmission needs a rebuild. I was looking online and found some for an 2003 for cheap. If I use that, My speedometer wouldnt work correct? Could I just change out the cluster with one from an 03?
richid is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04/24/2010, 02:22 AM   #2 (permalink)
Shut up.
 
wright06jhs's Avatar
 

Join Date: Jul 2006
Location: Lexington, Ky
Vehicle: 2007 Infiniti G35X
Posts: 3,700
wright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends here
Send a message via MSN to wright06jhs
Its not the cluster that's the problem, So no swapping the cluster wont work. It something to do with the speed sensors and such, i dont feel like looking it up. A little bit more searching will find you the EXACT answer.

You can also use a transmission out of a 99-01 3.0 Galant as well.

try car-part.com
__________________
07G35x|Premium|15%tint|HKS|Zwheels|TopSpeed|BC BR Coils|

My Ride

G35Driver
wright06jhs is offline   Reply With Quote Quick reply to this message
Old 04/24/2010, 12:36 PM   #3 (permalink)
Junior Member
 

Join Date: Apr 2010
Posts: 3
richid : who are you?
so by using a transmission from a 99-01 3.0 galant, the speed sensor would still work?
richid is offline   Reply With Quote Quick reply to this message
Old 04/24/2010, 12:55 PM   #4 (permalink)
SktLsr7
 

Join Date: May 2007
Location: California SFV
Vehicle: 01 Eclipse Spyder Gt
Posts: 314
sktlsr7 : who are you?sktlsr7 : who are you?sktlsr7 : who are you?
Send a message via AIM to sktlsr7
Galant = Eclipse but in a different body.
sktlsr7 is offline   Reply With Quote Quick reply to this message
Old 04/24/2010, 03:14 PM   #5 (permalink)
Shut up.
 
wright06jhs's Avatar
 

Join Date: Jul 2006
Location: Lexington, Ky
Vehicle: 2007 Infiniti G35X
Posts: 3,700
wright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends herewright06jhs has a few friends here
Send a message via MSN to wright06jhs
Quote:
Originally Posted by richid View Post
so by using a transmission from a 99-01 3.0 galant, the speed sensor would still work?
Yes, that's why i said you CAN use that transmission.
__________________
07G35x|Premium|15%tint|HKS|Zwheels|TopSpeed|BC BR Coils|

My Ride

G35Driver
wright06jhs is offline   Reply With Quote Quick reply to this message
Old 05/24/2010, 02:34 AM   #6 (permalink)
Boobs!? WHERE!?!
 
Solar Klipse's Avatar
 

Join Date: Mar 2010
Location: Norfolk, VA
Vehicle: 03 Eclipse 3.5L GT
Posts: 1,030
Solar Klipse : who are you?Solar Klipse : who are you?Solar Klipse : who are you?Solar Klipse : who are you?
Yeah I think it's the actual pinning of the connectors that would cause the RPM loss on your cluster. Alot of minor changes were made to the electrical system when they changed to 3rd gen mk 2. Just search for speed sensor pinning... I think.
__________________
Quote:
Originally Posted by beatums View Post
the trannies might not fail but the drivers do. check a local junkyard
You Got Electrical Questions? I've Got Answers!

6G72/74 Engine Swap
ECU Reflash/Tune (Courtesy of TX4Codeman)
AEM V2 CAI
RPW Long Tube Headers
KYB AGX Shocks
Tein S-Tech Lowering Springs
EBC Slotted Rotors
Stoptech SS Brake Lines
F1 Racing Stage 3 Clutch
F1 Racing Lightened Flywheel
Ingalls Stiffy Engine Damper
Solar Klipse is offline   Reply With Quote Quick reply to this message
Old 06/20/2010, 06:47 AM   #7 (permalink)
AWD & TT
 
MyShadow's Avatar
 

Join Date: Nov 2007
Location: Russia - Moscow
Vehicle: 2001 Eclipse GTX 3.0TT
Posts: 110
MyShadow : who are you?MyShadow : who are you?
Send a message via ICQ to MyShadow
You'll have a problems with gear ratio, each AT have a specific gear ratio (if you're right - you got F4A51-2 E5B1 one), so, if you install the F4A51-EZB or F4A51-LZB you'll have SES on your tranny ECU: Gear Ratio Incorrect ...

I'm also have the same problem, my previous tranny got blown gasket of torque convertor and many details were damaged, while driving without oil in AT. So I bought an contract one from Galant '01, but on 4000 miles of driving it - i'm feeling, that clutch packet is coming to the end and internal pressure in AT is descenting every week.
So i decided to buy IPT rebuild kit and rebuild it with my self. I would cost just about 1000$ with uninstall/install with service. + new oil.
Mitsubishi / DSM Transmission Rebuild Kit
MyShadow is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Club3G Forum : Mitsubishi Eclipse 3G Forums > Eclipse General Discussion > 3G Eclipse General Discussion

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club3G Forum : Mitsubishi Eclipse 3G Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off





All times are GMT -5. The time now is 02:29 AM.
Search Engine Friendly URLs by vBSEO 3.3.0
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.