Immobilizer problem, eclipse 03 GS - Club3G Forum : Mitsubishi Eclipse 3G Forums
Go Back   Club3G Forum : Mitsubishi Eclipse 3G Forums > Performance & Tech Forums > 3G Eclipse RS/GS Specific
Club3G Decals

Club3G.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 09/06/2009, 04:17 PM   #1 (permalink)
Junior Member
 

Join Date: Sep 2009
Location: Panama city
Vehicle: Lancer EVO IV
Posts: 3
arty turbo : who are you?
Immobilizer problem, eclipse 03 GS

Hi guys,

"Is it possible to disable the immobilizer (feature) from the Eclipse 2003 2.4 MT ECU?"

"The ECU was damaged, therefore I bought another one and it is not starting the car. Most likely due to the Immobilizer"

I tried disable it like I've done with EVOs and it is not working.

ROM: 90920006

I appreciate your help.
arty turbo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09/07/2009, 10:17 PM   #2 (permalink)
Junior Member
 

Join Date: Jun 2009
Posts: 28
darkmitsu : who are you?
I was unable to do it, some people say your able to , I ended up having to get an evo ecu and disabling the imoblizer in it...
darkmitsu is offline   Reply With Quote Quick reply to this message
Old 09/11/2009, 10:22 AM   #3 (permalink)
Junior Member
 

Join Date: Sep 2009
Location: Panama city
Vehicle: Lancer EVO IV
Posts: 3
arty turbo : who are you?
I already have the original ECU (MR578582), which I got a great deal on. I can't buy another (EVO) ECU right now, so I want to know my options with the one I got.

Any ideas on why the same procedure on the EVO ECU won't work on this ECU? Any more information would be apretiated.
arty turbo is offline   Reply With Quote Quick reply to this message
Old 09/11/2009, 07:58 PM   #4 (permalink)
Junior Member
 

Join Date: Jun 2009
Posts: 28
darkmitsu : who are you?
the problem with the one you have is not all the table have been mapped within the xml files in ecuflash, if you figure out how to make yours work please share...
darkmitsu is offline   Reply With Quote Quick reply to this message
Old 09/15/2009, 12:57 PM   #5 (permalink)
Junior Member
 

Join Date: Sep 2009
Location: sarasota,FL
Vehicle: 2000 eclipse gt
Posts: 27
dalesocks : who are you?
Send a message via MSN to dalesocks
???

hello i currently have the same problem in my 2000 eclipse gt m/t federal specs.the ecm was bad so i replace it with a rebuild one.but then they tell me thta i need to replace the ecu immobolizer. But mitsubishi says that they dont know the ecu is gonna work with the ecm i bought online so they want me to buy their ecm and charge me 1500 dollar. do you guys think my total rebuild ecm will work with the factory stock ecu immobolizer?? please let me know what you think im desperate.
dalesocks is offline   Reply With Quote Quick reply to this message
Old 09/21/2009, 08:07 PM   #6 (permalink)
Member
 

Join Date: Apr 2007
Posts: 35
hastur : who are you?
The ECU Immobilizer is one of the ECU periphery0 bits into the ROM, located at address FAA into my 03 RS (90920009) ROM. I would guess that it is at the same address into your ROM too. What I have found related to the periphery bits is that there are multiple copies of each periphery flag, and changing only the one at FAA didn't work for me, when I disabled my 2nd O2 sensor check. My original ROM contained 56DA at address FAA, and after disabling the immobilizer you would have to set this value to 56DE.

You have two options :

1. start ecuflash, open ECU periphery 0, and disable the immobilizer at FAA. After, right-click on the periphery 0 table and edit the table definition. Change the FAA address for FAC and then click ok. Change the immobilizer bit again, then edit the file definition again and again until the 8 copies of the periphery bits are done. You have to change it for FAA, FAC, FAE, FB0, FB2, FB4, FB6 and FB8. Do not forget to reset your table definition to FAA at the end.

OR

2. Use a hex editor like XVI32 (which is free) and load your ROM (not the XML, the ROM) and go to address FAA, and change the 56DA to 56DE, you will clearly see the copies of the flag one after the other from FAA to FB8. Change them all to 56DE and you're done.

Good luck, and be careful with what you do with your ROM.

Jeff
__________________
2003 Manual RS Eclipse
RPW Camshaft Stage 1 N/A M/T profile
CMF header
Magnaflow Hi-Flow Cat
Greddy SP2 60 mm Exhaust
Custom Magnaflow 14" / 2,5" Resonator welded in
AEM V2 Intake
GT Throttle Body
Magnecor Ignition Wires on Denso Iridium Plugs
Street tuned using EcuFlash and Evoscan

Last edited by hastur; 09/21/2009 at 08:13 PM.
hastur is offline   Reply With Quote Quick reply to this message
Old 09/24/2009, 09:02 PM   #7 (permalink)
Junior Member
 

Join Date: Sep 2009
Location: Panama city
Vehicle: Lancer EVO IV
Posts: 3
arty turbo : who are you?
Problem solved, engine start, excellent information,

thank you very much Jeff.

arty turbo is offline   Reply With Quote Quick reply to this message
Old 12/17/2010, 04:22 PM   #8 (permalink)
Member
 

Join Date: Nov 2010
Posts: 31
01mitchell : who are you?
Quote:
Originally Posted by arty turbo View Post
Problem solved, engine start, excellent information,

thank you very much Jeff.

HANG ON i having this exact problem i had to get a remaned ecu and now my car wont start i called mitsubishi and they said the ecu and the immobilizer need to be a match set... What did you do to fix this? PLEZ HELP
01mitchell is offline   Reply With Quote Quick reply to this message
Old 12/17/2010, 04:43 PM   #9 (permalink)
R.I.P. silverside
 
finesse49ers's Avatar
 

Join Date: Dec 2007
Location: PharmEcis' shop/house & Queens, NYC
Vehicle: '03 6G75T, '98GSX, EVO IX
Posts: 10,932
finesse49ers seems to be well-liked by allfinesse49ers seems to be well-liked by allfinesse49ers seems to be well-liked by allfinesse49ers seems to be well-liked by allfinesse49ers seems to be well-liked by allfinesse49ers seems to be well-liked by allfinesse49ers seems to be well-liked by allfinesse49ers seems to be well-liked by allfinesse49ers seems to be well-liked by allfinesse49ers seems to be well-liked by allfinesse49ers seems to be well-liked by all
Send a message via Yahoo to finesse49ers
Quote:
Originally Posted by 01mitchell View Post
HANG ON i having this exact problem i had to get a remaned ecu and now my car wont start i called mitsubishi and they said the ecu and the immobilizer need to be a match set... What did you do to fix this? PLEZ HELP
Dude, this thread was well over a year old before you bumped it. I'm going to give it to you straight and tell you something you probably don't want to hear. At this point you mine as well get your mindset to eat that $450 you spent fooling with the guys you're fooling with and accept that as a loss. Buy drunkoffjuic's ECU for $40 and see if he could work it out where the immobilizer is deleted before you get it or get yourself a tactrix cable and get in contact with any of the guys I recommended and ask them if they could walk you through deleting the immobilizer.
__________________
Building THE GREATEST 3G to date and possibly EVER built by PharmEcis. MIVEC 6G75 Turbo 5 Speed AWD.

This is what I'm about: The 3G, 1998 GSX, EVO IX GSR.

Quote:
Originally Posted by kevin711 View Post
Whens the car going to be finished with the turbo and everything on it

Quote:
Originally Posted by PharmEcis View Post
Kevin: It'll be done when I'm done with it... ;)
finesse49ers is offline   Reply With Quote Quick reply to this message
Old 01/10/2013, 12:55 PM   #10 (permalink)
Member
 
kiger250's Avatar
 

Join Date: Apr 2012
Location: Pittsburgh
Vehicle: 2003 Eclipse GTS
Posts: 62
kiger250 : who are you?
The dealer ship charged me $80 reprogrammed the key to match with the ecu and the immobilizer and whala
kiger250 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Club3G Forum : Mitsubishi Eclipse 3G Forums > Performance & Tech Forums > 3G Eclipse RS/GS Specific

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club3G Forum : Mitsubishi Eclipse 3G Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off





All times are GMT -5. The time now is 09:22 AM.
Search Engine Friendly URLs by vBSEO 3.3.0
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.