Eclipse dies when RPM gets below 2000, dies while driving. help please! - Club3G Forum : Mitsubishi Eclipse 3G Forums
Go Back   Club3G Forum : Mitsubishi Eclipse 3G Forums > Eclipse General Discussion > 4G Eclipse General Discussion

Club3G.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 02/27/2015, 07:33 PM   #1 (permalink)
Junior Member
 

Join Date: Feb 2015
Posts: 4
CF89 : who are you?
Eclipse dies when RPM gets below 2000, dies while driving. help please!

Hey guys, my girlfriend has a 2007 mitsubishi eclipse that is giving her major problems.

sometimes it will just die going down the highway and not start back up for 10 minutes.

sometimes she needs to keep the gas pedal pressed down and keep the idle above 2000 RPM or it will die.

sometimes it runs great!!

took it to a mitsubishi dealership and they couldnt figure it out (like wtf??) and said it runs fine.

I am personally thinking its the fuel pump.

has anyone ever heard of this before or have any suggestions?

any advice would be greatly appreciated.

thanks!
CF89 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05/05/2015, 03:32 PM   #2 (permalink)
Junior Member
 

Join Date: May 2015
Posts: 4
Shawnn50 : who are you?
im having similar issues but lemme post my thread in here.

"I have 3 codes running I know what all three are for, to mention I did just break an 02 sensor hitting a curb but I have had this issue since I bought the car a year ago.
p0157 cyl 2, 3 heated oxygen sensor(rear) Low Voltage
p0037 cyl 1, 4 heated oxygen sensor Heater (rear) Control Circuit Low
p0102 Mass Air Flow Circuit low input

Any suggestion on what to replace, what to check. Any one have a fix? When I reset the codes they usually come right back as I start the car.

Just recently I found out that the cats are cut out and the top two o2 sensors have what someone called "Foolers" on them. When I went on Ebay or Google turns out they are called spacers. "
Shawnn50 is offline   Reply With Quote Quick reply to this message
Old 05/05/2015, 03:34 PM   #3 (permalink)
Junior Member
 

Join Date: May 2015
Posts: 4
Shawnn50 : who are you?
Someone recently suggested that it may be the fuel pump. I just started working at a shop and both mechanics really have no idea they are kind of just like it may be this but that might not fix it.

Some days it runs fine other times ill be going 60 and itll just start to stop reacting to the gas pedal until I slow down all the way and it turns off. Then itll turn off but and start but die immediately several times before running again. Then its all sluggish and when it gets to 4k rpms basically taps out like Im supposed to shift or something but its auto.
Shawnn50 is offline   Reply With Quote Quick reply to this message
 
Old 06/16/2015, 09:40 PM   #4 (permalink)
Your Reality Check
 
ICEMAN99TURBO's Avatar
 

Join Date: Feb 2001
Location: Bad Axe, MI **Welcome 2 HICKTOWN**
Vehicle: Y2K GT-P
Posts: 31,339
ICEMAN99TURBO seems to be well-liked by allICEMAN99TURBO seems to be well-liked by allICEMAN99TURBO seems to be well-liked by allICEMAN99TURBO seems to be well-liked by allICEMAN99TURBO seems to be well-liked by allICEMAN99TURBO seems to be well-liked by allICEMAN99TURBO seems to be well-liked by allICEMAN99TURBO seems to be well-liked by allICEMAN99TURBO seems to be well-liked by allICEMAN99TURBO seems to be well-liked by allICEMAN99TURBO seems to be well-liked by all
Send a message via AIM to ICEMAN99TURBO Send a message via Yahoo to ICEMAN99TURBO
IAC... Idle Air Control?.... If it was a fuel pump you would either have fuel or nothing, they don't show signs of dying like say a battery or wiper motor.
ICEMAN99TURBO is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Club3G Forum : Mitsubishi Eclipse 3G Forums > Eclipse General Discussion > 4G Eclipse General Discussion

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club3G Forum : Mitsubishi Eclipse 3G Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off





All times are GMT -5. The time now is 02:32 PM.
Search Engine Friendly URLs by vBSEO 3.3.0
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Valid XHTML 1.0 Transitional Valid CSS!