Lots of sqeaking in rear suspension, Need some help - Club3G Forum : Mitsubishi Eclipse 3G Forums
Go Back   Club3G Forum : Mitsubishi Eclipse 3G Forums > Performance & Tech Forums > Eclipse Performance

Club3G.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 04/14/2016, 05:26 PM   #1 (permalink)
Junior Member
 

Join Date: Jan 2016
Posts: 7
kspinazzola6 needs to be reminded to breathe.
Lots of sqeaking in rear suspension, Need some help

So, ever since I got my car there has been a little sqeaking in my rear pass side suspension, I figured it was a bushing but now it has gotten quite a bit worse and I went and looked through the entire rear end and I think I found it.

One of these chassis parts under the spare tire holder has a huge hole in it, rusted through I guess,
I'm not sure what the part is called so I haven't been able to order a new one, does anyone know what this thing is called? Its behind the sway bar links and other suspension parts.
It looks like a bolt in part so hopefully wont be too hard to replace.

Second question is what do you guys recommend for replacing it? Is there a higher performance part I can buy somewhere or should I just get an OEM replacement?

Here is the pic
http://kspinazzola.imgur.com/all/

Last edited by kspinazzola6; 04/14/2016 at 05:35 PM.
kspinazzola6 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04/25/2017, 06:42 PM   #2 (permalink)
Junior Member
 

Join Date: Jan 2017
Posts: 20
1gcrazy : who are you?
I can't see in the picture very well but if a part fits in that massive hole and that's actually the chassis, you'll need to drill the spot welds and get a replacement from the junkyard. Then you can fix and align as normal. No sense in patching something with that much cancer.
1gcrazy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Club3G Forum : Mitsubishi Eclipse 3G Forums > Performance & Tech Forums > Eclipse Performance

Tags
chassis, repair, squeaking, suspension, sway bar

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club3G Forum : Mitsubishi Eclipse 3G Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off





All times are GMT -5. The time now is 06:35 AM.
Search Engine Friendly URLs by vBSEO 3.3.0
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Valid XHTML 1.0 Transitional Valid CSS!