Club3G Forum : Mitsubishi Eclipse 3G Forums - Reply to Topic
Go Back   Club3G Forum : Mitsubishi Eclipse 3G Forums > Performance & Tech Forums > Wheels/Tires/Brakes/Suspension > Rear endlinks question

Club3G.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Thread: Rear endlinks question Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Club3G Forum : Mitsubishi Eclipse 3G Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
03/21/2017 07:41 PM
Leeroy you also need to grease them up, if you dont they will rust
03/15/2017 12:32 AM
3G Runner You're the second person to mention this issue as well.

Quote:
Originally Posted by Leeroy View Post
So i have a noob question. i got my moog k4732's today. i noticed that one of the rear end links that i got was really easy to move the ball joint (it wasn't lose but required little to no effort to move it)while the other k4732 needed a lot more force to move the ball joint. Here is my question, is this normal? or should i return the end link that is really easy to move the ball joint?
03/12/2017 10:29 PM
Eclipse-GT
Quote:
Originally Posted by Bitter View Post
I can't say I've ran into that, were they all of the same design? Moog has rolled out a new 'internal' boot for some parts which have had issues with boot failures, they look weird but they work better. I've not ran into a freely spinning moog part. However, were they K or RK series moog? RK is more or less the same as any other part, K is the problem solver line which is the 'real' moog.
Yeah I did notice that difference. However, yes they are the problem solver version all around. When I say freely I mean I could literally move it around like an old Atari joystick style freely. Both rear end links as well as the passenger front right were like this on both ends. The driver's side was solid as were the inner and outer tie rods and also the front lower ball joints. They also all had boots, grease loaded in already and came with self tapping grease fittings which were such a pain to even get started on some. Once I got to the defective ones I didn't even bother.

Just have to send these back for replacements. First time I've ever had issue with Moog. To be clear, this isn't Rock Auto's fault. I guess I either got a bad batch or from the look of some of the boxes being opened and missing plastic bagging that they were returns or something misplaced. Glad I found out and was able to go over everything else within the order to make sure before I started wrenching away for nothing.
03/12/2017 05:48 PM
Leeroy return them. when i did my coils i got some end links. they were easy to move little to no pressure, which is not normal. they should be stiff. they also send me the wrong grease things that screw on, be careful with those. play it safe and get a different set.
03/12/2017 12:09 PM
Bitter I can't say I've ran into that, were they all of the same design? Moog has rolled out a new 'internal' boot for some parts which have had issues with boot failures, they look weird but they work better. I've not ran into a freely spinning moog part. However, were they K or RK series moog? RK is more or less the same as any other part, K is the problem solver line which is the 'real' moog.
03/12/2017 11:43 AM
Crazyguy03 Not good and very odd as well....
03/12/2017 10:50 AM
Eclipse-GT Checked through the rest of my Moog suspension parts order from RockAuto and also noticed my front right side end link has the same problem. It spins ridiculously easy compared to the left side which is very stiff like it should be. Most of the Moog boxes packed inside the main shipping box from RockAuto were opened and reclosed as well. Some in the plastic they come shipped in while others were not. Ironically enough the ones in plastic were the ones messed up while the ones not were ok. No idea but pretty sure these parts should all be very stiff and hard to move when new. I mean after all if you can move them freely that is when they're usually replaced so I set up a return on the defective parts for replacements. Sucks to be put behind schedule but what can ya do.
03/12/2017 10:25 AM
Eclipse-GT
Rear endlinks question

So I just ordered new rear endlinks, went with Moog of course. Got them out of the boxes and they're already greased and ready to go. Just have to insert the grease fittings which seem to be self tapping because they do not screw in easily. Not a big deal. What is a question of concern though is that one endlink is very solid as in I cannot freely move it. I believe, through years of replacing them, that this is considered normal and that they should be pretty stiff because opposite is bad. Well one is able to be moved freely, way too freely as I can spin both ends freely in all directions with ease. I'm guessing one is defective? It is definitely new but this makes me question using it or returning it to RockAuto. Thoughts?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On




All times are GMT -5. The time now is 02:49 AM.
Search Engine Friendly URLs by vBSEO 3.3.0
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Valid XHTML 1.0 Transitional Valid CSS!