weird idle issue - Club3G Forum : Mitsubishi Eclipse 3G Forums
Go Back   Club3G Forum : Mitsubishi Eclipse 3G Forums > Performance & Tech Forums > Problem Reports

Club3G.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 01/20/2019, 04:17 PM   #1 (permalink)
Junior Member
 

Join Date: Oct 2012
Posts: 4
Jnspayne : who are you?
weird idle issue

2003 Eclipse GTS: Just went over 300k

The car is idling at around 1400rpms and fluctuating to 1500rms intermittently. Sometimes it stops when the car in in neutral and the clutch disengaged. Most of the time it happens when the clutch is engaged. If you release the clutch just to the point of friction, it goes away, but still idles too high.

I have replaced the IAC, cleaned the throttle body and ERG and replaced the EGR solenoid. I did fiddle with the idle screw when I cleaned the throttle body. Probably should not have touched it. The screw is almost in all the way at 1400 rpms idle.

I will probably replace all the vac hoses next, just in case. Would a throttle body from a junk yard be the way to go. Maybe the TB hasn't been messed with. TPS?

Looking for ideas.
Jnspayne is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01/20/2019, 11:22 PM   #2 (permalink)
Stage 1 SDS @11+ psi
 
repforenzo's Avatar
 

Join Date: Apr 2005
Location: Crofton, Md.
Vehicle: 2003 GTS 5sp.
Posts: 2,869
repforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regular
Did you take the TPS out? You need to put that in the right position. You'll need a login program to see if you had 0% when the throttles close and 100% when it's wide-open.
repforenzo is offline   Reply With Quote Quick reply to this message
Old 01/20/2019, 11:57 PM   #3 (permalink)
Junior Member
 

Join Date: Oct 2012
Posts: 4
Jnspayne : who are you?
Yes. I took the TPS off. Not my best moment. Should have researched first. Do I need to take it to the dealer or is this something I can do myself
Jnspayne is offline   Reply With Quote Quick reply to this message
 
Old 01/21/2019, 07:48 PM   #4 (permalink)
Stage 1 SDS @11+ psi
 
repforenzo's Avatar
 

Join Date: Apr 2005
Location: Crofton, Md.
Vehicle: 2003 GTS 5sp.
Posts: 2,869
repforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regularrepforenzo should be considered a regular
The tps needs to be clocked properly. Get a logging program (EVO Scan is great but you have to get a Tactrix 1.3 or 2.0 cable/adapter) so you can confirm 0% and 100%.
repforenzo is offline   Reply With Quote Quick reply to this message
Old 01/22/2019, 10:19 PM   #5 (permalink)
Junior Member
 

Join Date: Oct 2012
Posts: 4
Jnspayne : who are you?
Thanks. It looks like the 1.3’s are getting hard to find.
Jnspayne is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Club3G Forum : Mitsubishi Eclipse 3G Forums > Performance & Tech Forums > Problem Reports

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club3G Forum : Mitsubishi Eclipse 3G Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off





All times are GMT -5. The time now is 05:50 PM.
Search Engine Friendly URLs by vBSEO 3.3.0
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Valid XHTML 1.0 Transitional Valid CSS!