1990 D150 - Club3G Forum : Mitsubishi Eclipse 3G Forums
Go Back   Club3G Forum : Mitsubishi Eclipse 3G Forums > Other Automotive Discussion > SUV/Trucks

Club3G.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 06/30/2017, 12:44 AM   #1 (permalink)
Member
 

Join Date: Apr 2016
Location: Forsyth, Ga
Vehicle: 2003 GTS Spyder
Posts: 51
TyGeR needs to be reminded to breathe.
1990 D150

Hello, hoping some of the awesome gear heads in here can give me some ideas. I have a 1990 D150 with a 318 V8 that's giving me a problem. It has a misfire on Cylinder #7. I have changed coil, dis cap, rotor button, crank position sensor (plate under rotor button), wires, plugs. side note that all this stuff was changed about 6 months ago before I bought the truck. Fires up fine but you can hear a misfire. So I use a plug tester (the one that plugs into the plug wire then onto the spark plug that has the light), go from cylinder to cylinder. All cylinders show to be firing good with the exception of #7. The light on the tester is very weak, will go out for a few seconds then comes back very weak. Swap plug wires, same thing. Used tester between dis cap and plug wire, same thing. All the old parts looked ok, checked the dis cap, its on tight, rotor button doesn't seem to have any issues. I don't have any clue what to try from here. Everything from the coil to plugs is new. Battery is good. My only thoughts at this point is that it is something wrong with the bottom part of the distributor.

If the distributor was out of time could that cause only 1 cylinder to fire really weak? I would think if this was the case it would cause an issue across all cylinders.

thank you for any advice.
TyGeR is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Club3G Forum : Mitsubishi Eclipse 3G Forums > Other Automotive Discussion > SUV/Trucks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club3G Forum : Mitsubishi Eclipse 3G Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off





All times are GMT -5. The time now is 06:38 AM.
Search Engine Friendly URLs by vBSEO 3.3.0
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Valid XHTML 1.0 Transitional Valid CSS!