Mitsubishi Eclipse 3G Club banner

distributor

  1. Problem Reports
    Hi all, been lurking for a bit on this forum, never posted before now. Anyway, my car is an '01 Chrysler Sebring but it has the 3.0 DOHC used in the similar year eclipse. So I had a really bad shaking problem to my car, came out of nowhere. So i eventually went to check the codes throwing my...
  2. Problem Reports
    Hey guys! (2001 GT Auto) So I figured out why the car wouldn't even try to catch. My spark was way off timing. Looked at the dizzy and it was not even put all the way in lol. It is hard to set with the cap on into the cam. I searched and saw instructions by Silver about cranking the engine...
  3. Problem Reports
    Let me start by saying I've searched to the best of my ability, but if the answer to my question already lies in the forum, please link me to it. Back in October my timing belt got stretched out too much. (3.0L) I went ahead and had my timing belt, water pump, cam seal and distributor replaced...
  4. New Members Forum
    I am a new member and I have a 01 gt, I put a 2002 motor in it and have read about the cam reluctors being different. so as soon as the cam sensor malfunction and crank sensor malfunction codes popped up, even though car seemed to run ok, I changed the reluctor. since i have done that the engine...
  5. Problem Reports
    2004 Eclipser Spyder, 3.0 6 cy, automatic, will crank fine but never try to start. No fire at plugs, no pulse at injectors Thought alarm was keeping it from starting and had alarm and ignition switch checked out by local alarm installer, Key recognition seems to be working as can arm alarm by...
Top