Mitsubishi Eclipse 3G Club banner
grinding
1-7 of 7 Results
  1. Problem Reports
    I'm having a weird problem with my 2001 Spyder GT automatic. Under heavy acceleration there is a nasty grinding sound from the engine bay, it does it in 1st, 2nd, and 3rd gear (haven't tested 4th because that would be a little too fast), it also does it in neutral/park sometimes. This is an...
  2. Problem Reports
    Okay so I have a 2002 gt with about 130k miles on it. I am experiencing two issues: 1. it has a very weak idle and makes a whistling noise, but no code is being shown. 2. the car vibrates/shakes and makes a loud grinding/gurgling noise when driving over 30mph, when accelerating over 2000-2500...
  3. Problem Reports
    I purchased a 2004 Spyder GT about 6 months ago. Since then I have replaced the starter, Radiator, Spark plugs, Wiring, One O2 sensor, Two oil changes and pretty much all fluids topped off/changed. My problem right now is that when I start the car I hear a metal grinding sound. It sounds like a...
  4. Problem Reports
    Alright so I found a good condition 2002 Eclipse GS that I'm thinking about buying. 112k miles. Runs like a dream and shifts out great, except for one problem, there is a grinding noise when shifting from a stop to first, or from neutral to first. All the other gears shift out just fine, and if...
  5. Problem Reports
    Hey everybody, I know this is my second problem this week, I just don't have the money to take my car in. I have a 2000 GT sporty, which again, has been sitting for 6 months. I put in a new starter, and battery, so it starts now, but it makes a grinding/rattling/ticking sound which you can find...
  6. 3G Eclipse GT/GTS Specific
    i was driving my '01 gt 5-speed today, went to shift from 3rd to 4th, all of the sudden the rpm's go way up, i instantly smell burnt clutch, i have no clutch pressure after repeatedly pressing it to the floor, and my transmission wont go into gear at all, it's stuck in neutral. so i coast off...
  7. Problem Reports
    I have 2002 eclipse RS 5spd that just hit 150,000 miles, she has a 1.5 inch drop ( my husband did it for me over a year ago, I think they are tein but Ill double check) and 3 days ago when I started her up after 3 days of not driving I heard a noise. Before I get into the noise: Ive done oil...
1-7 of 7 Results
Top