Mitsubishi Eclipse 3G Club banner
no power
1-8 of 8 Results
  1. Problem Reports
    Hi. I've a 2004 Spyder GTS (US, LHD) and when using the central console's cigarette lighter as a power source for an air-pump (flat tire), the pump cut out and I found the plug really hot – overheated. It failed to reconnect in the cigarette lighter socket afterwards (although it worked using...
  2. New Members Forum
    I have problem with the alternator charging the battery. I've been through 2 alternators already had this one in car, pulled it out and had it bench tested. Passed all the tests threw it back in. And check for charging nothing. I all ready disconnected all harness cables in engine bay checked...
  3. New Members Forum
    I have a 04 eclipse spyder gts manual with the stock original 6G72 with 247000 miles on it. About a month ago every once in a while the engine would mis a little( just assumed it was the spark plug so didn't worry about it) then I was driving down the highway at a constant speed and the car just...
  4. Problem Reports
    Seen the forums for a while, bought a GT a few weeks ago, now first post time. OK guys I'm really worried and would appreciate any help. Was on my way to work today, got off the freeway and the car won't run anywhere near right. I got to the end of the off ramp and then it wouldn't rev up...
  5. Problem Reports
    So I have been searching and searching and cannot find anyone with a similar problem. Seems like most people have a small misfire at idle or have a small misfire while driving and throw a P0300. This is not the case for me... My car is a 2000 GT (3.0L obviously) with ~145k on it. It's also a...
  6. Problem Reports
    I new to the forums and have searched other posts but there not exactly like my symptoms so I'll post my own issue. Here's the deal I have an 00 eclipse gt which recently got hydro locked. I was able to fix it and it ran fine for a while, until one day it started rough idling a lot like 400 to...
  7. Problem Reports
    Model: Eclipse Year: 2001 Submodel: GT Miles: ~147k Trans: manual Mods: None Problem Description/History: A few weeks ago I noticed that my SES light was illuminated. Upon having the car scanned at Autozone, I was told that it was throwing a Random/Multiple Cylinder Misfire (P0300 I think) as...
  8. Problem Reports
    Road trip down the interstate and my Service Light Comes on, so i pull off, check the gas cap, pop the hood. nothing strange. I keep driving and mileage is fine (replaced all 4 O2 sensors a few monthes ago) and the engine wasn't overheating or making any noises. Get to where I'm going and swing...
1-8 of 8 Results
Top