Mitsubishi Eclipse 3G Club banner
problems
1-20 of 38 Results
  1. Problem Reports
    New to these forums and can’t locate problem. So I have a brand new alternator and battery, got them 2 days ago. When I start the car, my lights flicker for a bit and stop, but come back every now and then, the car stays above 1000rpms when in park, and stays high/fluctuates when in any other...
  2. 3G Eclipse General Discussion
    So I'm currently looking at getting coilovers and a MAF sensor from MaXspeedingrods.com, but I'm still having gauge issues, my fuel gauge and oil temp gauge are the only ones that work, the speedometer reads 0mph at all times and the tachometer reads incorrectly jumping and going above where rev...
  3. New Members Forum
    My car has a loud rattle/tap at start up. But it doesn't happen all the time, very inconsistent but often. Does anyone else have this? I've heard it could be a lifter but it is much louder than a lifter tap, and it seems to be coming from the left side of my engine bay. My car is a 2005 3g...
  4. Problem Reports
    So i was in the process of changing out the light bulbs on the gauge cluster i ended up shorting something out. Acquired a new cluster and now im showing codes for the transmission and its stuck in limp mode. It goes into reverse and park it just doesnt shift whatsoever. I was wondering if...
  5. 3G Eclipse General Discussion
    For the past month my GT has been running rough (spitting, sputtering, terrible gas mileage, exhaust smell, running rich, black smoke out tailpipe). I mean it was barely getting me to work. I'd have to play with the clutch and accelerator anytime I got into traffic just to keep it from dying on...
  6. Car Audio and Electronics
    i have noticed lately my 2 led lights on my rear view mirror blink once every 3 to 5 mins when the car is off, sort of like an alarm but my car has no alarm besides the oem kill switch... what could this be? any ideas lately ive done alot of electrical works big 3 is done all 0 awg gauge CCA...
  7. Problem Reports
    Hey guys, I'm trying to figure this out. I've got the 2002 Mitsubishi Eclipse Spyder GT convertible (which I keep having problems withdespite it's general reliability. I'm not the best with cars but I try to fix my own problems as much as possible to save money. My center Brake light works...
  8. New Members Forum
    Hi guys. I'm new, and completely lost on where to get some advice for my car. I have a 2003 Mitsubishi Eclipse GS, automatic 4 cyclinder, and I believe it's a 2.4 engine. It's at about 103k miles, I just bought it from AutoNation 2 months ago, and on the last day of my warranty, it started...
  9. Problem Reports
    Hello, i new here, and this is my first post. Anyway, before i go to the problem(s), im going to give a little background on my car. i bough a 2000 gt eclipse about 10 months ago it has 185.xxx miles (i know, a lot). and honestly, this car is a pain in the a**. it wasn't running when i bought...
  10. Problem Reports
    Okay guys, I am out of options. I am desperate. For starters: 2002 Eclipse GT 170xxx miles Around two weeks ago my car randomly quit while driving. I started it right back up and it ran fine. Well, the problem got worse. It quit again the next day and refused to start again. I checked the...
  11. Problem Reports
    Hi, I have a 2003 eclipse gts 5 speed. Once I am in third and try to rev the car past 5,000 rpm I get this weird hissing noise. I am not loosing any power and once it goes about right under 5,000 everything sounds normal. Help?
  12. Problem Reports
    When starting, my 3.0 liter 2000 manual transmission eclipse turns over strong. While the battery is charged the car has no problem turning over. I have to pump the gas for my car to start. When running there is no loss of performance and no hesitation. It has a clean fuel filter and band new...
  13. RS/GS
    I have a few questions about my car. I have a 2003 Eclipse GS Automatic Turbo, I recently just had my kit installed and every time I put the pedal to the floor it sounds like my fuel sputters out (injectors/pump can't keep up) at around 4/5k RPMs. I upgraded my fuel pump to the fuel pump that...
  14. Problem Reports
    I am having problems with my 2002 Eclipse GS. I noticed that my compressor is working because i could hear the noise whenever i turn on the AC. However, the AC clutch turns on and off like every three seconds.... i tried recharging the freon by putting an entire can from Auto Zone. but no...
  15. New Members Forum
    Both on my phone and on my computer (FireFox and Google Chrome), the WSCP website isnt working right. Everytime I click on 'View' on an item on the site to look at, it just pulls up an error page, then the entire '/store/' portion of the site doesnt work at all, I only get an error message...
  16. Problem Reports
    Ok so I need help or advice on heater core issue. I have no leaks from any hoses but I noticed the drain pipe for heater for fluid was pouring out I drove it a mile and all my fluid just came out through it and started to get hot. I have thought of bypassing heater core but my buddy says if I do...
  17. 3G Eclipse General Discussion
    I have recently bought a 2000 gs auto has CE light on and i have been trying to fix it because I am getting 16/18 MPG AND burn through a QT of oil every 400-500 Miles and when stopped at light with car in drive it idles at 500 rpm and vibrates when i push it in neutral re turns to 800-900 rpm...
  18. Car Audio and Electronics
    Hey guys, I got an 03 GT with an aftermarket deck and shitty Pioneer speakers that the owner before me put in. I have a problem where after my battery is disconnected and reconnected, no sound comes out of the speakers, just a very low frequency bass that you can only hear if you turn the volume...
  19. Problem Reports
    So I'm having a few odd ball problems with my 03. When I bought the car about 2 months ago it seemed fine. No check engine light, everything electrical worked fine and engine was smooth as could be. But now I'm having some issues one after the other. Nothing serious by any means just keeps...
  20. Problem Reports
    So ive searched all around the fourms many of times and im stumped. Car: 2002 Mitubishi Eclipse 3.0l V6 Spyder Miles: 203,000 My heat kind of works... If i drive my car with the heat off and then turn it on i will have heat for a little while but then it gets cold. Seems like lack of flow in...
1-20 of 38 Results
Top