Mitsubishi Eclipse 3G Club banner

troubleshooting

  1. Car has no power after tune up?

    Problem Reports
    I have a 2000 GT manual transmission. I just replaced all of the spark plugs, wires, cap & rotor, along with new valve cover gaskets, upper intake manifold gasket, egr tube gasket, and also a new accelerator cable. After completing the work described above I started the car up and it was idling...
  2. iCarsoft i909

    3G Eclipse General Discussion
    Does anyone have any information on this diagnostic tool for Mitsubishi and Mazda vehicles? I have been trying to find out about it compared to the MUT-ll tool.
  3. GT Turbo Troubleshooting

    GT/GTS
    Last week, Thursday the car was running fine for the day - drove it for a while, but had stalled out a couple of times. Let it sit for a bit and was able to continue. Friday, one of the hose couplings (from turbo compressor to IC piping) worked itself loose but I was able to fix that. However...
  4. problems with newly installed turbo

    GT/GTS
    I finished my new turbo install and it runs good, no check engine light for 400 miles now, runs like stock.. but thats only till I hit 3,000rpm.. thats when I start getting a howling sound.. grows louder and louder like a wolf. When I reach 4,000 RPM I start getting a bogging kinda effect.. the...
  5. URGENT!!!

    GT/GTS
    Alright, we have Neffarious;s old motor in Lawerance' scar and all is great except no spark it seams. I was at a loss, we have the distributor set correctly and the plug wires in the right spots, still no fire. We have fuel and damn sure air, but no spark. I started to wonder if the distributor...
  6. e-manage folks, help out!

    GT/GTS
    Ok, so my e-manage has been on a couple weeks now, and I'm slowly workin' on getting the kinks worked out of the tune. It *seems* like I've gotten it to stop throwing codes tonight, as long as I stay off the boost until the ECU checks are done. Rides smooth under normal cruising conditions...
  7. Shit is coming together...

    GT/GTS
    So...a couple weeks ago, I was finally able to get me e-manage installed, and do a quick bit of road tuning with it. (I had finally had it with the Grey box doing a shit job and not being able to make corrections to it myself. I'm sick of either shipping the thing off, or driving to freaking...
  8. emanage help

    GT/GTS
    I started to tune with the emanage tonight and I cannot keep the car from dying at idle. I have 310cc injectors so I have the 210/310 injector correction and nothing, I tried 210/370-410-440-480 and nothing the car just dies after like a min or so of rpm going up and down. when the rpms drop to...
  9. E-Manage issue ????????

    GT/GTS
    Hey guys, Need some help if you can I drive a V6 5sp....and got Neffarious turbo kit. Got everything installed and started her up. It idled fine, so I decided to take her for a quick drive, started to stumble and run VERY VERY rich. I got her home and started to truble shoot. Tryed to connect...
  10. Engine will not turn over

    GT/GTS
    Engine will not start I just installed the SDS, I have yet to drive it! I started it up a week ago and it ran fine while i was waiting for my bushings to come back. Now the car is on all four wheels and it wont turn over. I replaced the plugs thinking those went bad that fast, nothing. I again...
  11. please tell me this is normal!

    GT/GTS
    i just changed my injectors for my sds. got the fuel pump in too. after i got everything back together, i tried starting it to test it. it started up but made an inconcistant tapping noise. almost like something was trapped in one of the cylinders but i had it masked off so i doubt that's it...
  12. Boost gauge question

    GT/GTS
    Hi everyone, I was driving back home this evening and I noticed something was off with my SDS. I tried to punch it for a little bit and I noticed something a bit odd. Here the details: Relevant setup: Five speed GT Stage 1 SDS Boost gauge 30 In Hg – 20 PSI Scenario: I was doing about...
  13. What's popping?

    GT/GTS
    Ok... here's another ET-true story for you! :) Picked the car up earlier today :woot: and what can I say... feels great! ... with a lot of quirks. Turbo/FMIC. Drive is normal, considering I'm missing both post-cat o2 sensors. But after driving an hour or so in straightaway traffic, I noticed 2...
  14. Car wont start

    GT/GTS
    I just recently had my sds intalled by tearstone so i know the installation isnt a problem factor here. I ran my car with a test pipe for the first 160 miles due to not knowing i had to have a cat on. The car ran very rich. Well i had a cat shipped over night was on my way to the shop to have...
  15. P431, P175, P172

    GT/GTS
    I don't get many replies over at RIPPs forums so I thought I would try it out here. I have had massive problems with this whole SDS thing and I ran into another one. I am throwing P431 almost daily, and almost every other day I am throwing P175 and P172. For thos who don't know what these...
  16. SDS Problems

    GT/GTS
    Ok, It has been almost 3,000 miles now and I am still throwing P300 and P302 codes daily. I checked the fuel grommet and it looks fine. I hold a steady 52 PSI of fuel pressure. When I shut off the car though it will not hold 20 psi of pressure for 20 seconds. It holds 10 for about 10 seconds and...
  17. SDS headache update

    GT/GTS
    SDS headache update **updated even more** Well.. I finally got the MT ECU installed, flashed, and running. Car is MUCH smoother now. I'm still getting P300 codes, but at this point I'm going to chalk those up to fouled plugs. However, I'm still running rich, and dont have anywhere near the...
Top