Mitsubishi Eclipse 3G Club banner
1 - 4 of 4 Posts

·
New Ride, New Ideas
Joined
·
109 Posts
Discussion Starter · #1 ·
I have a 01 GT with an automatic transmission and about 135k miles on it. Just over a year ago I had the rack & pinion replaced due to some minor issues causing it to fail a virginia inspection.

A couple days ago, after driving the car for perhaps 20 mins and making a turn, the steering wheel seemed to hit a barrier. I was able to pull hard on it and after a good bit of resistance (and what felt like grinding in both the steering wheel and gas pedal) it suddenly loosened again and turned fine. It then did this a few more times while driving it home. Later, my roommate, who is more skilled in car mechanics than I took it for a test drive and it never did it for him. Concerned, I took it to the shop that replaced the part today and in the 10 minute drive to the shop (with numerous turns) it did it one time, while making the turn into the shop. Shop took it for a test drive and of course, they had no problems.

So I'm a bit lost as to what it might be exactly. Power steering fluid looks fine and appears to not be leaking. There's no noticeable play in the steering wheel. Engine seems to run fine. I'm still dead set there's something wrong with the rack & pinion though the shop said it might be my power steering pump slowly going bad. But would that really cause a "grinding" feel in the steering wheel and gas pedal when pulling hard to turn it?
 
1 - 4 of 4 Posts
Top