Mitsubishi Eclipse 3G Club banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Sorry if this is already on here but I've looked and can't find anything I have an 02 Eclipse GT Spyder weak spark already put a new timing belt and firm timing is correct cylinder leak down test new crank sensor power to the distributor is correct I think it's the immobilizer but not 100% sure found a ECU immobilizer and key on eBay but it's 4 a Montero wondering if they're interchangeable the numbers do not match the numbers on my ECU if you guys can help me and appreciate it when I get this thing done before the winter turns to cold
 

·
Registered
Joined
·
468 Posts
You have a weak spark or no spark? Does the engine run? What makes you think it's a spark issue in the first place?

Your immobilizer has nothing to do with a weak spark and neither do any of the other things you've done. The more questions you answer/info you provide the more we can help.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I have a weak spark or spark no spark condition engine will not fire crank but will not start cough but again will not start all timing components are new including distributor crankshaft sensor getting about 4K when I get Spark
 

·
Registered
Joined
·
468 Posts
Did you buy an OE distributor and crank sensor? These cars don't like aftermarket sensors and have issues. Are you smelling a raw gas smell after cranking the engine? Have you verified you have fuel pressure? It sounds more like a lack of fuel to me.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Yeah we even brought it back and tried another crank sensor just in case it was bad out of the box I do smell raw fuel after cranking
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Okay confirm today for a fact it is a spark issue not fuel so anybody got any ideas about spark then no spark weak spark
 

·
Registered
Joined
·
468 Posts
Okay confirm today for a fact it is a spark issue not fuel so anybody got any ideas about spark then no spark weak spark
You said you're only seeing 4k volts from the distributor? Are you using an adjustable gap tester to see when spark no longer jumps the gap? The thicker black/white stripe power wire to the distributor runs directly from the MFI relay so you should always see battery power when the key is in the ON position. The cam and crank position sensors only tell it when to fire.
 
1 - 7 of 7 Posts
Top