Mitsubishi Eclipse 3G Club banner

21 - 35 of 35 Posts

·
Registered
Joined
·
12,548 Posts
You wouldn't make 5000 on a built block if you're using Ripp electronics.

Regardless, that's probably the cleanest 200k I've ever seen.
 

·
2000 EclipseGT owner
Joined
·
29 Posts
Currently have a 2000 GT A/T with 202,000 miles. Hoping it makes it to at least 250k before it gives out. Props to the man with the 300k Eclipse great job dude.
 

·
FROM MEXICO
Joined
·
156 Posts
I have now 193400 miles on my 3G and i need to know which oil are you using in your car's, because i have a problem with that.
In two week I changed the motor oil in two twice.

first when i bought my car i use 10W30 semisynthetic, worked fine on 4 months,
then started to lowering the temperature and had a noise in my motor, i think on the valves cover, so one person told me i had to change the motor oil now for 20W50.

then i did it and not work the noise stay there so add Lucas oil additive and the noise also.

then i read in the owners manual that the oil has to be 5W30 or 10W30, so i bought synthetic 5W30 oil, the thursday my car works well and today the noise is there again. i bought the lucas oil additive synthetic and I added also

tomorrow i hope that noise disappears but if dont do it ...

I need to know what you think or what would you do or advice please


please help !!!!
 

·
Fossilized Member
Joined
·
1,204 Posts
Thread resurrection!!

Ran across this thread in a google search. I guess I should post for a change. Just hit the mark this morning.



Still on the original engine and transmission. 3rd timing belt and second radiator. Other than that, very little has been done to the car except for routine maintenance and tires. Front brake pads lasted 95K miles and rear pads lasted 135K miles. Haven't had to change them again yet. I keep it waxed and maintained and we're still going strong.

B.
 
21 - 35 of 35 Posts
Top