Mitsubishi Eclipse 3G Club banner
1 - 17 of 17 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
Hello,

I have a 2003 5-speed Eclipse GTS that's bone stock with 90k miles and I keep getting the P0303 cyl. 3 misfire code. It came on in 3rd gear at around 4,000 rpms. First i bought new spark plugs and wires then had a mechanic install them because I didn't have the time to get to the 3 in the back. I reset the battery then boom I'm scooting up a hill in 3rd gear about 4,000 rpms and it comes on again. So this time I buy a new distributor cap and new Rotor, reset the battery again. Another day I'm goofing around 3rd gear 4,000 rpms and pow, like clockwork it comes on again and its the same code still! When the light comes on my car loses power but sounds and runs smoothly, just a bit slower. I heard there was some kind of safety mode that cars go into when the CEL comes on? If i reset the battery and the code goes away it'll run strong but give it a week and that light will come on again and it'll slow down again. Anyone else have this problem ?
 

·
TxTuning.com
Joined
·
6,812 Posts
You have quite a few options in finding out what exactly is wrong with the cylinder.

Since you have told me you have new plugs, wires, cap, rotor, the first thing I would question are the spark plug tube seals. That being is there oil leaking into the tube causing this misfire. To find out if this is the issue you will have to pull your plenum, remove the ignition wire, and look inside to see if there is oil.

If you do not find any oil, the problem (even new) can be caused by the spark plugs or ignition wires. To test this, you can swap the wires and plugs with another cylinder. When I had cyl 4 misfire, I swapped the cables with cyl 4 and 6, and wala- cyl 6 misfire. Hopefully the length of the wires between cyl 3 and cyl 5 are long enough so you can swap them.

This will be a good head start for you. Beyond this I could only assume the problem being either the cylinder itself (compression test), or inside the distributor. Good luck.
 

·
Registered
Joined
·
5 Posts
Hey. i know this wont be much help to you at all. but my 04 gts just read a cyl.2 misfire. so i just bought new ngk wires and plugs. and am having a guy i know instal them. since i have no idea how to remove the plenum. but the reason im posting on here. is. i saw someone talk about the spark plug tube and seals. i removed my valve cover. and one of the seal that are on the cover to the tube. seems messed up. and stays on the tube when the other two come off with the cover. so my question is. does anyone know where i can get a new valve cover and seals for it? ive called around and the only place ive found was the dealer, and thats just to expensive. so any advice? thanks.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #8 ·
I've never taken the intake plenum off, so maybe he did screw me and not even change the ones in the back. I'm going to try to take that off this weekend, i'm not that mechaniclly inclined and no spelling bee winner either :)

No holes that i can see, the light came back on again after i reset it,, again lol
 

·
R.I.P. silverside
Joined
·
10,932 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #10 ·
Oh hey thanks for the guide. I took it to a shop to have them diagnose it and he said they think its the fuel injector. He said he flushed the fuel injectors and reset the cpu and to let them know if the light comes on again..
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #11 ·
Is is possible to get access to the fuel injectors in the back without taking the plenum off? Or did they just dump fuel injector cleaner in and call it a day? I think Import / Export tire F'd me on this one..
 

·
R.I.P. silverside
Joined
·
10,932 Posts
Is is possible to get access to the fuel injectors in the back without taking the plenum off? Or did they just dump fuel injector cleaner in and call it a day? I think Import / Export tire F'd me on this one..
If you have your car then you should be able to look and figure out the answer about the rear fuel injectors. It's looking more apparent that nothing was done on Bank 1 and you got f'd.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #13 ·
Hello,

P0303 isn't showing after they flushed my fuel injectors but now it's saying P0175.
I have a question,
What does that honeycomb shaped grill do inside the MAF sensor ? Mine has a minor minor ding in it, it's tiny but it's there.
 

·
Registered
Joined
·
13 Posts
You have quite a few options in finding out what exactly is wrong with the cylinder.

Since you have told me you have new plugs, wires, cap, rotor, the first thing I would question are the spark plug tube seals. That being is there oil leaking into the tube causing this misfire. To find out if this is the issue you will have to pull your plenum, remove the ignition wire, and look inside to see if there is oil.

If you do not find any oil, the problem (even new) can be caused by the spark plugs or ignition wires. To test this, you can swap the wires and plugs with another cylinder. When I had cyl 4 misfire, I swapped the cables with cyl 4 and 6, and wala- cyl 6 misfire. Hopefully the length of the wires between cyl 3 and cyl 5 are long enough so you can swap them.

This will be a good head start for you. Beyond this I could only assume the problem being either the cylinder itself (compression test), or inside the distributor. Good luck.
Hello! Brand new to this forum... Anyways! :)

I have a 2003 Eclipse RS (4-cyl) and just changed the plug wires and plugs. It was my wife's old car, and she never really took care of it. Anyhow, it has just over 100,000 miles on it, and I just had the timing belt & water pump done.

So the other day when I changed the plugs and wires I noticed that upon removing the plugs they were like 1/2 submerged in oil. I replaced them w/ new ones anyways because it was already too late and figured if any oil drained into the cylinders it would just burn off.

Well then I got the P0303 cylinder 3 misfire code. My question is, I just bough a new valve cover gasket and spark plug seals. Once I replace those should that do the trick? Will I need to replace the plugs again? Any help is REALLY needed...I don't have a car right now. :(

Thanks for the help guys...​
 

·
j 2 the Gal
Joined
·
7 Posts
Hey. i know this wont be much help to you at all. but my 04 gts just read a cyl.2 misfire. so i just bought new ngk wires and plugs. and am having a guy i know instal them. since i have no idea how to remove the plenum. but the reason im posting on here. is. i saw someone talk about the spark plug tube and seals. i removed my valve cover. and one of the seal that are on the cover to the tube. seems messed up. and stays on the tube when the other two come off with the cover. so my question is. does anyone know where i can get a new valve cover and seals for it? ive called around and the only place ive found was the dealer, and thats just to expensive. so any advice? thanks.
Valve tube seals usually come in the pack sold by Fel-Pro for our cars, sold at most auto parts stores. If you don't want to buy all the gaskets, I use this site quite often. 6G72 73 74 Mitsubishi Valve Cover Gasket Set V-6 SOHC 24 Valve

As far as the valve cover, check out Car-Part.com--Used Auto Parts Market they mostly seem to have anything I am looking for. Replace valve cover seals with ones from link above!
 

·
Registered
Joined
·
13 Posts
Ok so I replaced the valve cover gasket and spark plug tube seals. The spark plug tube seals were pretty shot...not pliable at all and sort of "crushed."

I took the negative battery cable off for 10-minutes, put it back on, and then restarted the car. It's still running REALLY rough, and I'm still getting the P0303 cylinder 3 misfire code. The idle is all F-ed up at 2k RPMs or below, but if I rev it over that it's pretty smooth. WTF gives?!

Is this the correct firing order in the link below? Pissed...

2003 Mitsubishi Firing Orders
 

·
Registered
Joined
·
15 Posts
Hello,

I have a 2003 5-speed Eclipse GTS that's bone stock with 90k miles and I keep getting the P0303 cyl. 3 misfire code. It came on in 3rd gear at around 4,000 rpms. First i bought new spark plugs and wires then had a mechanic install them because I didn't have the time to get to the 3 in the back. I reset the battery then boom I'm scooting up a hill in 3rd gear about 4,000 rpms and it comes on again. So this time I buy a new distributor cap and new Rotor, reset the battery again. Another day I'm goofing around 3rd gear 4,000 rpms and pow, like clockwork it comes on again and its the same code still! When the light comes on my car loses power but sounds and runs smoothly, just a bit slower. I heard there was some kind of safety mode that cars go into when the CEL comes on? If i reset the battery and the code goes away it'll run strong but give it a week and that light will come on again and it'll slow down again. Anyone else have this problem ?

Having this same issue. 76 mph 4000 rpm. P0303 Code. I've done All spark related parts. Did you ever solve this issue? Someone please let me know.
Hello,

I have a 2003 5-speed Eclipse GTS that's bone stock with 90k miles and I keep getting the P0303 cyl. 3 misfire code. It came on in 3rd gear at around 4,000 rpms. First i bought new spark plugs and wires then had a mechanic install them because I didn't have the time to get to the 3 in the back. I reset the battery then boom I'm scooting up a hill in 3rd gear about 4,000 rpms and it comes on again. So this time I buy a new distributor cap and new Rotor, reset the battery again. Another day I'm goofing around 3rd gear 4,000 rpms and pow, like clockwork it comes on again and its the same code still! When the light comes on my car loses power but sounds and runs smoothly, just a bit slower. I heard there was some kind of safety mode that cars go into when the CEL comes on? If i reset the battery and the code goes away it'll run strong but give it a week and that light will come on again and it'll slow down again. Anyone else have this problem ?
Did you ever manage to solve this issue? Currently it's my issue.
 
1 - 17 of 17 Posts
Top