Mitsubishi Eclipse 3G Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hello everyone! Long time lurker, finally decided to post up what I've been doing. I bought my eclipse about 18 months ago. Replaced alot of suspension and steering parts, basic maintenance on the engine. Sensor replacements, and so so so much "wishful thinking."... Well I finally decided to change that and ordered pretty much everything I need to turbo the 4g64. All budget items (Ebay and Amazon) except for the turbo exhaust mani, 2g MAF, and the k03 turbo (Used from local sources)... So because I'm trying to budget build as much as possible I decided to first try spending $0 on the turbo. My brother replaced the turbo on his TT and the stock k03 is still in great condition, still bought a rebuild kit and going to try something different. There's a 3-bolt to 4bolt mainfold flange adapter I picked up and hopefully wont be too much of a hassle to use. My only issue coming with this are the oil and coolant feed lines... From the research I've done, it looks like I'll probably have to use the stock lines from my brothers A4 quattro (hopefully they'll be long enough or I'll maybe have to use compression fittings to extend them??)

So, I'll be adding a bunch of info to this later and over time (Pics included) but for now I'm goona make it kinda quick (Pregnant GF wants to go to lunch lol)

When I decided to finally go FI I had just replaced my stock injectors with 440cc blue injectors (I think? Could use help clarifying on these. I've gotten mixed info) and also replaced my radiator cap (stock was destroyed causing an ass-load of problems because the coolant wasn't pressurizing.) When I replaced the radiator cap it finally pressurized the system fully and caused my head gasket to fail on the timing belt side leaking fluid all over the timing components.... Sooooo, the head is off and getting cleaned along with the block surface (By me lol.) Going to take the water pump out to check how that's doing (just replaced 5k miles ago when I did the timing but timing belt is off atm so better safe than sorry.) For the most part just waiting for parts to come in, everything should be in no later than October 1st.

I'll have pictures posted and video links to previous fixes and current situation later. If anyone has some tips or pointers, I'll take all the help I can get (especially with tuning ^_^). Till next time, stay lit and take care!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
So I ran into a few obstacles.... The adapter I bought for the exhaust mani; 3bolt to 4bolt, was much much bigger than anticipated and won't work at all. Luckily the guy I bought the manifold from had 2 old turbos laying around that were in a junker car he purchased. "Old honda turbos" he called 'em. He gave me one for free with the mani purchase and turned out it's a garret turbo used for the 95-97 eclipses, it's got very minimal shaft play, doesn't look like seals are blown.... Imma run it without doing the seals, staying optimistic with it... A bigger turbo is in my future, blowing this one would just speed up the process lol...

This is a pic of everything that has come in so far... Wideband, boost gauge, thermostat, last engine mount that needs replaced, half of my BOV (just the pipe. Didn't have the one I purchased so sending a new one in a diff color)
Don't mind the mess. Garage was used for storage for a long time, then parties, and more parties lol. Shared with 3 other people, and hard getting everyone to pick up their shit lol:
0924201738.jpg
When the decision of replacing the headgasket before turboing was made:
0918201509.jpg

Did the best I could wrapping it lol. Will still be better than not being wrapped:
0924202105.jpg
0924202105a.jpg
The back of the block was so nasty from the leaking head gasket:
0921201958.jpg
I have alot more pictures and stories, but time is always something I don't have. I have to find em all, and get them posted...
I've spent the last couple days just cleaning stuff up, and kinda mocking up how I'm goona do everything, get a mental picture. I think tomorrow or Saturday I will drop the fuel tank and run new lines, and get it ready for the 255lph walbro to come in. Possibly figure out my pillar setup and where the rest of my gauges will go lol. Till next time, stay lit and take care!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
I actually just found a few more pictures ^_^
Pistons after first round of cleaning:
0923202309_HDR.jpg
The flange I ordered, that is waaaay too big:
0923202310.jpg

The turbos been sitting outside for awhile. Look at all that rust -_-:
0923202311.jpg

0923202251.jpg
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Valve cover is just there to run lines. Have a replacement I have to clean up and install.
43320
After installing the intercooler and piping, went to put the radiator back in, and have some fitment issues. Good news though, is that im pretty sure I can remove some piping from the turbo output, put the radiator in, and install the piping afterwords.. Goona attempt that later today.
43321
The Westgate actuator nipple on this turbo was snapped off(free turbo from a friend) so I took the actuator from the k03, did some cutting, fitment and welding, and she works perfectly.
43322
43323
 

·
Registered
Joined
·
5 Posts
View attachment 43323 what are the specs on that turbo? I have a 2003 rs eclipse that I am doing a turbo build on and im at the tuning stage, I have a t3/t4 63ar turbo off ebay as my test subject to see if its worth getting a name brand one, it looks like you have so much more room than I do between my radiator and turbo lol, ill get a pics if youd like to see. Great build though looks like its coming along 👍
 
1 - 6 of 6 Posts
Top