Mitsubishi Eclipse 3G Club banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
ok so i have a 2003 3G and did a 1997 6G74 swap, i had no problems with the swap and got it running and everything, but now its running shitty ( never did run perfect) and ever since i did the swap my alternator wont come on. I replaced the alternator and still nothing, not the fuse either. in the swap i relocated my battery into my trunk, and ran my grounds to the strut tower.
i also removed the cruise control and the EGR, so i decided to remove and plug the vacuum lines and unplugged all the EGR and cruise components.

One question i need to ask is dose the uploaded basemap tune i got for the swap go away when the battery is disconnected?


Any help would be greatly appreciated :yesway:
 

·
TxTuning.com
Joined
·
6,814 Posts
No, a tune is not erased when pulling the battery. Flashing the ecu with EcuFlash overwrites the ROM completely.
 

·
Back from Deployment
Joined
·
2,001 Posts
You've got to insure pos (+) connections unbroken from the alternator, starter and fuse box supply to the battery. From the factory these are all connected together at the pos terminal on the battery. Also make sure you plugged the plug into the alternator. I'm sure you know that already, but double check.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
yea the way i did my battery relocate is by attaching my wire to the stock positive battery terminal with the built in fuse. so that should all be the same.
 
1 - 5 of 5 Posts
Top