Mitsubishi Eclipse 3G Club banner
1 - 8 of 8 Posts

·
Donate 4 Life
Joined
·
3,767 Posts
Discussion Starter · #1 · (Edited)
Yes, I've searched for and found the AC light flashing... but this is also happening when I try to use the defrost with just the fans. I had my alternator changed and a new belt put on so its not a slipping belt. I've had already fixed the condensation problem under the cubby. I havent had a chance to check the relay of fuse yet. The AC Compressor wouldn't have anything to do with the defrost would it? Or the other way around with the HeaterCoil or whatever it is:scared: I've checked the coolant and it shows it's in the red (mechanical problem) on my gauge?
 

·
(b)org banugee
Joined
·
4,549 Posts
The AC gets turned on automatically when defrost is engaged. It helps dry the air. Since you know it's not the belt, go ahead and check the electrical items.
 

·
Registered
Joined
·
358 Posts
was that with the compressor running or off? also, how warm was it under the hood when you tested it?
 

·
(b)org banugee
Joined
·
4,549 Posts
how about something simple like the green light behind the button for the AC?
No. If the light is flashing, it indicates a problem with the AC system. Period. The AC is automatically turned on whenever the defroster is engaged.
 

·
Donate 4 Life
Joined
·
3,767 Posts
Discussion Starter · #6 ·
was that with the compressor running or off? also, how warm was it under the hood when you tested it?

It's not any hotter than normal... and the compressor isn't kicking on.. so it could either be the relay or the compressor itself.. I'm gonna change the relay first and check it again.:bigthumb:
 

·
Registered
Joined
·
223 Posts
It'll do this if the temp gets too hot or if you're in an extremely wet environment. Mine has done this a few times in downpour rain. The conditioning system simply can't handle all the moisture. Same if it's too hot, the system can't handle heat.
 

·
Premium Member
Joined
·
2,097 Posts
my 04 has handled several 100+ degree days. never gave me a problem. Although some condesation built up on my pioneer HU and caused it to go wacky for a hour or so.
 
1 - 8 of 8 Posts
Top