Mitsubishi Eclipse 3G Club banner
1 - 7 of 7 Posts

·
Cone Killer
Joined
·
1,297 Posts
Discussion Starter · #1 ·
So the past four or five days, my car has been randomly dieing when I'd start it. It happened once after school, we charged it ad got the battery and alternator checked and both were fine. After charging it worked fine for a day, then did it again. Completley dead. Jumped it then, haven't had a problem for days. Then did it again today. Im not leaving anything on or anything like that. I need help:scratch:
 

·
Premium Member
Joined
·
8,831 Posts
Sounds like your Alternator is going bad. Its not charging the battery enough to start the car.
 

·
Sword at the Ready!
Joined
·
390 Posts
Hmm maybe a parasitic draw test? But start at the very basics, corrosion, loose terminals, bad grounds, etc. 8/10 its something simple such as those or the battery may have enough voltage but losing its cca, seen those false positives where someone checks just the volts and it seems fine or borderline but the cca is way down.
 

·
Registered
Joined
·
1,866 Posts
Hmm maybe a parasitic draw test? But start at the very basics, corrosion, loose terminals, bad grounds, etc. 8/10 its something simple such as those or the battery may have enough voltage but losing its cca, seen those false positives where someone checks just the volts and it seems fine or borderline but the cca is way down.
:agreed:
 

·
Cone Killer
Joined
·
1,297 Posts
Discussion Starter · #6 ·
Hmm maybe a parasitic draw test? But start at the very basics, corrosion, loose terminals, bad grounds, etc. 8/10 its something simple such as those or the battery may have enough voltage but losing its cca, seen those false positives where someone checks just the volts and it seems fine or borderline but the cca is way down.
We did a double check and the terminals were actualy pretty lose so we cleaned them and the posts and tightened them down and seeing if this works. So far so good I'm hoping its something simple like that at least.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top