Mitsubishi Eclipse 3G Club banner

1 - 13 of 13 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter #1
Hey guys, yesterday my right brake light on my '02 Eclipse GT went out...but when hazards are on and when all my lights are on, it works, but for some reason it does not turn on when I push the brake pedal (even though the left one does). Is this some kind of blown fuse or wiring problem or something worse?

(also I dont know if they are related but recently my horn for the locking mechanism stopped working, and strangely enough my glovebox light, too.)

oh one more thing, they are not the stock taillights, they are the chrome euro taillights (dont know which company)

I need to fix this fast, I have enough traffic violations as it is...anyone have input?
 

·
Registered
Joined
·
1,690 Posts
I could have sworn the hazard lights make the turn signals blink, not the tail lights...:scratch:

I'd say you just have the bright portion of that bulb burnt out...it happens, just buy a new bulb...
 

·
Registered
Joined
·
111 Posts
Discussion Starter #3
ha yeah you are right, I had a friend helping me out and he said the hazard thing...yeah that would be turn signal (which has no problem)

but when the lights are on at night it works...thats great if it is a bulb its going to suck replacing it because I dont know what company makes the lights, nor have I ever had to replace a taillight bulb.
 

·
Registered
Joined
·
1,690 Posts
You're making this into something much bigger than you need to. The tail lights have a dual filiment...they're on at a low level with the headlights, and get brighter when the brakes are applied. Just go into any parts store and tell them you need some 2057 bulbs...they come in 2-packs, so you can just replace them both if you want. Even though you have aftermarket tail light housings, the bulbs are still the same...
 

·
Registered
Joined
·
1,690 Posts
...and if you're really worried about it, most parts stores will install the bulbs for you free...
 

·
Registered
Joined
·
111 Posts
Discussion Starter #6
oh okay, I'll stop at a store and do that tomorrow...thanks for the help!

hey and would you have any idea about the cause of the horn not working when I lock the car with the remote?
 

·
Medic
Joined
·
2,354 Posts
Kidney_bean and i are horn experts.:rofl: See if the horn is still good to begin with before i get into detail. Wire from Battery to the horn above the driving horn.
 

·
Registered
Joined
·
223 Posts
Check to make sure your brake switch (by the firewall) isn't stuck. If you're in a snowy area, the spring inside can get rusted up pretty quickly.
 

·
Registered
Joined
·
1,690 Posts
Check to make sure your brake switch (by the firewall) isn't stuck. If you're in a snowy area, the spring inside can get rusted up pretty quickly.
He said that only the right brake light went out...if the switch was bad or stuck none of the brake lights would work...
 

·
Registered
Joined
·
111 Posts
Discussion Starter #12
wait so does that mean I'm back to the changing the bulb? (I still haven't had time to do anything about it yet)
 

·
Relapsed.
Joined
·
1,811 Posts
wait so does that mean I'm back to the changing the bulb? (I still haven't had time to do anything about it yet)
Change the bulb only a few bucks if that doesnt work look for the spring the tail light housing only has 3-4 bolts depending on year and is a pita to get to. lol
 
1 - 13 of 13 Posts
Top