Mitsubishi Eclipse 3G Club banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I don’t know a lot about cars so sorry for the vague description. But a week ago, at stop signs my car would shake, and sometimes, the engine would just stop. I’d be stepping on the brake and it will start shaking and eventually stop running if the stop light is long enough. And I’d have to start the car back up again to go. My trusted friend who owns a mechanic shop said it was the alternator, and replaced it with a new one. Yet here I am, with the same problem. Yet today, the engine will stop running no more than 2 seconds after I switch gears. I can’t even leave my drive way. The problem is at its worst on a cold start.
I have a 2004 Mitsubishi Eclipse GT.
VIDEO OF MY ENGINE -

here's a video in case u can hear a problem.
 

·
Registered
Joined
·
754 Posts
It seems to idle well and there's not enough info to properly diagnose the issue. It shuts off when coming to a stop? Or whenever it's hot? My guess is an idle air control and a hard reset of the ecu to lose learned values (disconnect battery for 5+ minutes) will fix the issue.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
It shuts off at stops, and when i have my ac too high. I’ll definitely try your suggestion, so thank you!
 

·
Stage 1 SDS @11+ psi
Joined
·
3,055 Posts
There is just simply not enough information to diagnose your car. It could be a vacuum leak or your fuel trims could be whacked out, TB needs cleaning, etc. etc. You need to put an OBD 2 scan tool on it to see if there are any pending codes... since you didn't mention a check engine light. Along with the scan tool I might suggest getting a vacuum gauge. Your car should be at -20 in.Hg at ~800 rpm.

I do not recommend messing around with the idle screw until you done the other checks. Many people don't realize that that screw has a direct relationship to the ISCV motor settings. You mess up that adjustment, your idle will always be hunting.
 

·
Registered
Joined
·
4 Posts
I had the same problem with my car and when I had to fix it it was eather my alternator or starter motor loose although I'm not sure on specific part that was replace it had to do with one of them
 
1 - 5 of 5 Posts
Top