Mitsubishi Eclipse 3G Club banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2001 mitsubishi eclipse spyder GS automatic 2.4L 4cyl, the vehicle turns over but doesn't idle on it's own i have to keep my foot on the gas pedal to keep it running as soon as i let off it stalls, RPM's go to 0 and no pressure on the gas pedal. It worked for a bit but the idle progressively got lower and lower an would stall if i reversed too slow, used to hesitate when taking off too. The temperature gauge is fucking retarded an moves if it wants to, an i get a good fuel smell when keeping my foot on the gas. THERE IS NO CHECK ENGINE LIGHT
History
Car overheated. replaced fuel resevoir(melted), radiator cap, and all fluids.
Check engine light was on, gave p0300 code replaced spark plugs and rubber hose on EGR valve because it was torn.
Cleaned MAF, IACV, and Throttle body. Installed new fuel pump assembly

I have a feeling it's a vaccum leak, or bad 02 sensor. but i'm still a rookie with working on vehicles.
Anyone have any thoughts it'd be great for some help, I'm on Camp Pendleton if anyone just happens to be nearby.
 

·
Registered
Joined
·
17 Posts
Had a similar issue with the idle for a while, finally took it to an independent shop and the guy told me my intake manifold was cracked. Replaced it, have not had a single idling issue since. Maybe check that?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top