Mitsubishi Eclipse 3G Club banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
First of all, yes i searched and didnt see anything that could help me. Heres the deal, i have a 5speed obviously and whenever i just hold the clutch in while im fixin to slow down, i find it very difficult to upshift if i keep it down too long. Almost like i let all the pressure out of it and it wont shift. Now if i keep it in neutral and let off the clutch for a few seconds then try it again, it shifts fine. Anybody got any ideas or fixes for this. No smartass comments please im fed up with this
 

·
BoomGoesTheDynaMitt
Joined
·
7,180 Posts
I dont understand the situation or the question...
whenever i just hold the clutch in while im fixin to slow down, i find it very difficult to upshift if i keep it down too long.
Why would you be pushing (and holding) the clutch in while you are preparing to speed up (upshift)? Based off my guess of what you are saying I'd be tempted to say look into changing the tranny syncros... but thats a major guess.
 

·
Registered
Joined
·
223 Posts
My .02... check the shifter cables on the tranny. You have to take the battery tray off to see it, but they're pretty easy to check. See if the rubber bootie things are warn.
 

·
Registered
Joined
·
77 Posts
your slave cylinder is probably crapping out, i bet if you move the rubber boot on it a bunch of fluid will piss out. Make sure the reservoir is topped off till you get it fixed
 
1 - 5 of 5 Posts
Top