Mitsubishi Eclipse 3G Club banner

1 - 11 of 11 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I am stalled at cold air intake 01 Mitsubishi Eclipse V6 3.0 now everytime I step down on the gas it wants to die. Is there something I need to do to the computer make this work?
 

·
Moderator
Joined
·
881 Posts
If it worked before you put the cold air intake on and doesn't after, the problem is with the installation, not the computer. It should run fine if the only thing you changed was the intake tube and air filter.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
All I did was remove air box install the air tube and the filter now it runs like shit dies every time you go to take off
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
It can sit there and idle so sweet and when you go to step on the gas to take off it will die it started this after I put the intake tube and filter on it
 

·
Moderator
Joined
·
881 Posts
Put the old one back on and see if that fixes your problem. If it does, the cold air intake install was botched.
 

·
Registered
Joined
·
36 Posts
Did you reconnect the smaller tube that runs out of it? Also double check your MAF connection and make sure thats secure and I would recommend disconnecting your battery for a few minutes and let the ecu reset, that will take away the dash lights.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #8
Everything is tight and everything is hooked up right every time I start the car when I try to take off it dies don't understand it
 

·
Vx_Lotus
Joined
·
20 Posts
MAF is likely in the wrong position, or no longer clean enough to pick up the sensor properly. ( I had this issue on a short ram intake, I moved the MAF closer the throttle body by 1 inch ) fixed my problem.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #11
I had to put the original airbox back on the cold air intake was just chewing up my air mass air flow intake I went through two of them
 
1 - 11 of 11 Posts
Top