Mitsubishi Eclipse 3G Club banner

1 - 20 of 44 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
My cruise light comes on whenever I press the button but it won't set. I looked into it awhile back but I don't remember what all I checked. I need to know what to check and how to fix it. Also, is there a specific fuse for the cruise control? I can't find it if so. I would really like to have cruise control working in my car so I can not dread long driving trips. Please help.
 

·
Registered
Joined
·
12,548 Posts
Yes there is a fuse, check your owners manual for the diagram. Otherwise pop the hood and find the throttle body. There is a round metal bell attached to it. That bell holds the diaphragm that operates on the throttle body. There is a vacuum hose that connects to that bell and runs to a hard line on the top of the intake manifold. A hose attaches to the other side of the hard line and runs to the left side of the engine bay where there is a little black motor that produces vacuum. Sounds to me like you either blew a fuse, the motor burned up, or the vac line is disconnected or broken.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
Alright I'll check that fuse later and if it's not that I'll check my vaccum line. Hope I can fix it. Thanks for the tips.
 

·
Registered
Joined
·
463 Posts
is your third brake light working?
or are you using an led light for the third brake light.
either of these will cause the cruise control not to set.
You might as well ask him if he changed his muffler barrings if you're going to ask a question like that.

But honestly it's probably a broken vacuum line, the light wouldn't come on if the motor was out or the fuze was out. they're like .80$ a foot at o'rileys or any other auto part store.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
Yeah my third brake light works. Pretty sure I'm not using an LED bulb. Probably just gonna buy another vaccum line and hope that works. And if not, well I'll make sure I don't have an LED bulb. And if it still doesnt work then I guess Ill have to do without cruise on long trips.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
I couldn't see anything wrong with it, but just in case I bought a new line last night since they're so cheap and I'm gonna put it on later today and pray that it works.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #9
I just replaced both ends of the vacuum line, still isn't working, what should I do now? iMonster said that the light wouldn't come on if the fuse or the motor was out so no point in checking the fuse or replacing the motor right? I'm clueless on what to try next.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #10
Still no cruise control. Someone please give me ideas of what to check now? Isnt vaccum line, already replaced it. I don't know how to check if the motor that creates the vaccum is working. I priced a module for around $40 but I don't know of replacing that would help or not. I would really like to have cruise control so someone please help me figure out what's wrong.
 

·
Premium Member
Joined
·
8,831 Posts
I understand that you checked the line but check vaccum on the round metal bell attached to the TB. That bell holds the diaphragm that operates the CC on the throttle body. If there is hole in that diaphragm vaccum will not hold.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #12
I replaced that piece of the vaccum line to. I know exactly what bell your refering to, and I don't want to sound stupid, but I don't know how to check the vaccum on the line. If someone could clue me in on how to then I could go about evaluating what pieces I need to replace next.
 

·
Premium Member
Joined
·
8,831 Posts
Lol, I'm sure this will sound stupid, but hook up a hose and start sucking. You should start to see the tb move and the flap open up inside the tb. When you get it to a point put your finger over the hose and hold. See if the tn starts to close. If so you know where the problem is.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #14
Wait...so I'm supposed to suck on the hose that connects to the bell looking thing that connects to the tb? Lol it sounds a little crazy but ill give it a try later. Ill be standing outside my apartment, up under my hood suckin on a hose...man what will my neighbors say if they see me doin that lol
 

·
Registered
Joined
·
24 Posts
Discussion Starter #16
Lol true dat. Ill be like what? cant a guy love his car these days? hopefully i wont make a fool of myself for no reason. i just want cruise in my car...and if i have to suck on a hose...well then i guess im gonna have to suck on a hose.
 

·
Premium Member
Joined
·
8,831 Posts
You can either do that or go buy one of these fuckers

Cant really test the CC unit as it will only engage once past 20-25 mph
 

·
Premium Member
Joined
·
8,831 Posts
:worthless:
 
1 - 20 of 44 Posts
Top