Mitsubishi Eclipse 3G Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Brake lights and turn signals work fine. Checked the fuse for driver side running lights, it was blown. replaced it and lights flashed then went out again (blown fuse again). It says use a 7.5 but when i got the car it had a 10 in that slot. Maybe because the guy installed those little hood lights on the washer jets hooked into that side. Worked for a month then this happened. Checked the bulbs and wiring that was accessible. No problems that I could see with the stuff I could get to. I checked all the fuses and every one of them is good except for #21 I think (Whichever is the left side parking lights). Is there maybe something I missed that could be a problem? Something common maybe? I know I saw another Eclipse GT with the same issue.
 

·
Fuck salt.
Joined
·
5,170 Posts
Well the little lights you have could be shorting the circuit out somewhere. That's why they should be hooked up to relays
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
I'm going to pull the connections off and see if it fixes my problem. What relay should it be hooked up to to keep them on when my running lights are on? Now, i'm new to this kind of work on a car and i'm not sure where they even are.
 

·
Fuck salt.
Joined
·
5,170 Posts
You need to make your own relays. Search on google how to wire a bosche relay with lights
 

·
Fuck salt.
Joined
·
5,170 Posts
Not make your own, I meant make your own circuits integrating relays. It's VERY easy
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
Well the little lights you have could be shorting the circuit out somewhere. That's why they should be hooked up to relays
I feel kind of stupid for chasing down wires. I let it sit in the garage and dry out for a while and it turns out one of my sockets was getting wet from a cracked turn signal. About those little hood lights, I decided they were a little ricey and just unhooked them all together. Thanks for the relay suggestion though!
 
1 - 6 of 6 Posts
Top