Mitsubishi Eclipse 3G Club banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I’m gonna start off by saying I’m new to the 3g eclipse. But not new to cars in general been working on them for a couple years now and am having a few issues for my eclipse and hoping anyone has any ideas. I’m currently not getting power to my speakers, obd port, or blower motor. I checked the fuses and I believe they are good. Not getting power to blower motor fuse either. I also wanna make sure I’m checking the correct fuse. My car is a 2005 eclipse gs. If anyone has any suggestions please help lol it’s getting cold out and would love for the blower motor to kick out some heat. Thanks
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
I’m gonna start off by saying I’m new to the 3g eclipse. But not new to cars in general been working on them for a couple years now and am having a few issues for my eclipse and hoping anyone has any ideas. I’m currently not getting power to my speakers, obd port, or blower motor. I checked the fuses and I believe they are good. Not getting power to blower motor fuse either. I also wanna make sure I’m checking the correct fuse. My car is a 2005 eclipse gs. If anyone has any suggestions please help lol it’s getting cold out and would love for the blower motor to kick out some heat. Thanks
And I’ve replaced the blower motor and resistor as well^
 

·
Super Moderator
2001 Spyder GT
Joined
·
699 Posts
@MightyWades said he has no power to his speakers. There will be no power there if the radio is not turned on... Is your radio working but without sound?
No power to the OBD Port or blower motor... While the video I have linked is not a Mitsubishi I think it would still apply to all vehicles... Hope this is helpful
 
1 - 3 of 3 Posts
Top