Mitsubishi Eclipse 3G Club banner
1 - 7 of 7 Posts

·
Registered
Joined
·
958 Posts
Discussion Starter · #1 ·
ok. So my car started out as a 2000 fed spec 5spd. Once I found out about the ecu flash with the evo rom, I decided that was the best route to go. I changed out the cam reluctor and got an 03 ecu and flashed the evo rom onto it. Ever sense then, It has been really hard to get my car tuned good. The AFR's are where they need to be, but drivability isnt the best. Low throttle driving isnt bad, but if I hit it the tach will drop to 0 and the car will feel like it doesnt want to move, but i build boost. This only happens from certain speeds. usually if I hit it from over 4000 rpms the car will move and the tach will work. anything below that and its retarded. I have messed around with the timing and it has fixed it some, but still not all the way. I noticed when logging with evo scan what when I first hit it, the load goes to over 300% and then drops down. I was wondering if that had something to do with it. Maybe the MAS scaling is wrong or injector latency or something. Does anyone have any solutions or pointers to help me out? Before when I had the stock fed spec ecu and emanage it didnt do this. and my set up hasnt changed. still running the same amount of boost on the same turbo. If it helps my set up is:
440cc injectors
evo3 big 16g
2G manifold
2.5" turbo back exhaust
snow perfromace meth injection kit
rpw stage 1 turbo cam
 

·
My snail is bigger!
Joined
·
1,154 Posts
I'm not familiar with your particular setup, but tach problems are always ignition related as the tach is triggered off the negative coil wire(s).
 

·
Registered
Joined
·
958 Posts
Discussion Starter · #4 ·
So it turns out it was the IFS. I jumped pins 3 and 4 and the cars is running great. now on to some more tuning and the new setup i have been waiting to put on. Thanks
 

·
My snail is bigger!
Joined
·
1,154 Posts
So it turns out it was the IFS. I jumped pins 3 and 4 and the cars is running great. now on to some more tuning and the new setup i have been waiting to put on. Thanks
For anybody who looks at this thread in the future, what exactly is the IFS? Injection Fail Safe on your Methanol Injection kit? I've got nothing.
 

·
New daddy
Joined
·
3,352 Posts
I belive it is the Ignition Failure Sensor. The early 4g64's didn't have knock sensors. So the sensor is checking for the presence of spark. If there is a missfire the sensor will pick it up.
 

·
Registered
Joined
·
339 Posts
Awsome I'm glad this worked. I'm probably going to have to do this as well when i install my evo ecu and turbo kit.
 
1 - 7 of 7 Posts
Top