Mitsubishi Eclipse 3G Club banner
1 - 9 of 9 Posts

·
Registered
2003 Mitsubishi Eclipse GTS
Joined
·
34 Posts
Discussion Starter · #1 ·
Okay so originally my speedometer worked but not my tachometer, I changed the face because the aftermarket one that came with the car blocked light from coming through, after that, both stopped working so I bought a used one on FB marketplace, the tachometer cuts in and out and doesn't read correctly, and the speedometer still doesn't work, all advice needed please, this issue is making me want to get rid of the car altogether, I traded a 07 Pontiac G6 for this car for a similar reason
 

·
Super Moderator
2001 Spyder GT
Joined
·
699 Posts
I have difficulty with a regular multi meter so I got myself a digital one that's much easier to use and read.. If the first speedo worked.. can you remove it and add it to the cluster you are using now.
Your problem could be the vehicle speed sensor ...
BWD SN7157 Vehicle Speed Sensor | TheWrenchMonkey Canada
This link is for a Canadian site but I`m sure you could find this part closer to you in the US like Rockauto.com
 

·
Low and Slow.
Joined
·
1,874 Posts
they both stopped working, although i found out my tach stays on if my seatbelt isn't buckled?
Sounds like a short. The seatbelt light comes on when you need to buckle the belt. You can try to remove the bulb on the dash for the seat belt light, then buckle and unbuckle the belt. If no changes, the bulb was helping complete the circuit when powered.
 

·
Registered
2003 Mitsubishi Eclipse GTS
Joined
·
34 Posts
Discussion Starter · #7 ·
There no visible seat belt light at all actually, I'm going to see if there are any blown bulbs in the cluster and replace them if so, I have 2 clusters so if need be I'll use the auto one for parts.
 

·
Registered
Joined
·
249 Posts
If I were you, I'd replace all the bulbs with new ones now, unless you dont mind pulling your cluster every time a single bulb blows.

btw, I agree that your problem is probably a short, but I'm no expert on wiring. And dont rule out the possibility that your used FB cluster is bad.
 

·
Registered
2003 Mitsubishi Eclipse GTS
Joined
·
34 Posts
Discussion Starter · #9 ·
If I were you, I'd replace all the bulbs with new ones now, unless you don't mind pulling your cluster every time a single bulb blows.

btw, I agree that your problem is probably short, but I'm no expert on wiring. And don't rule out the possibility that your used FB cluster is bad.
the FB cluster is good, I believe there's a short somewhere between the VSS and the cluster.
 
1 - 9 of 9 Posts
Top