Mitsubishi Eclipse 3G Club banner
1 - 20 of 20 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a 02 4g64 in an eclipses spyder. I rebuilt the engine (not my 1st rebuild, faa trained mechanic)and installed the turbo and equipment from a 97 gst including injectors and resistor and fuel pump and rail etc. Its timed correctly replaced one injector (no resistance across coil) rechecked wiring mod have spark, valve train normal(hold compression via leak down test) but engine runs ruff and ecu kicks out code for cyl 3 misfire swapped 8njectors around with no change.does any one have any ideas of what i could have missed i have yet to reprogram ecu (waiting for tatrix ecuflash to arrive) so any suggestion would be apreaciated . Thanks
 

·
Registered
2001 Spyder GT. Koni adjustable shocks. cold air intake, ST sway bar.17X8.5 rims. LED headlights.
Joined
·
566 Posts
If not the coil pack or wire, you might have an intake manifold leak at #3 cylinder. Have you sprayed something around the intake to see if it changes anything ? All the cylinders on the same O2 sensor should theoretically be making the same fuel mixture. Something makes #3 run different. ...J.D.
 

·
Registered
2001 Spyder GT
Joined
·
473 Posts
I have a 02 4g64 in an eclipses spyder. I rebuilt the engine (not my 1st rebuild, faa trained mechanic)and installed the turbo and equipment from a 97 gst including injectors and resistor and fuel pump and rail etc. Its timed correctly replaced one injector (no resistance across coil) rechecked wiring mod have spark, valve train normal(hold compression via leak down test) but engine runs ruff and ecu kicks out code for cyl 3 misfire swapped 8njectors around with no change.does any one have any ideas of what i could have missed i have yet to reprogram ecu (waiting for tatrix ecuflash to arrive) so any suggestion would be apreaciated . Thanks
You tested and swapped the injector, but did you check the electrical harness to make sure it's providing the electrical pulse to the injector?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
If not the coil pack or wire, you might have an intake manifold leak at #3 cylinder. Have you sprayed something around the intake to see if it changes anything ? All the cylinders on the same O2 sensor should theoretically be making the same fuel mixture. Something makes #3 run different. ...J.D.
Swaped coils no change checked resistor side of harness will check pulse side next thanks
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
Swaped coils no change checked resistor side of harness will check pulse side next thanks
No i puta new injector in that hole.
I did put a test light on 2 and 3 and i get a solid light and no noticeable pulse could the ecu be turning them on and not off? I assumed neg through the resiston would be constant nd the pos. Side the one pulsed am i wrong ?
 

·
Registered
2001 Spyder GT. Koni adjustable shocks. cold air intake, ST sway bar.17X8.5 rims. LED headlights.
Joined
·
566 Posts
To check those properly I think you need a Noid Light. I do not have one in my shop, so I'll leave that question to someone else to give you an
accurate answer. ...J.D.
 

·
Registered
Joined
·
567 Posts
No i puta new injector in that hole.
I did put a test light on 2 and 3 and i get a solid light and no noticeable pulse could the ecu be turning them on and not off? I assumed neg through the resiston would be constant nd the pos. Side the one pulsed am i wrong ?
You will not see pulses from a test light you need to use a noid light to see that happen or a oscilloscope
 

·
Registered
2001 Spyder GT. Koni adjustable shocks. cold air intake, ST sway bar.17X8.5 rims. LED headlights.
Joined
·
566 Posts
Guess it depends on the year of the car in question. Not all Mitsubishi V-6's are the same. As for the other, I do not speak Outlander, so I cannot say. I am on my 3rd. Mitsubishi though. A pickup, a 2g Eclipse. Now a 3g. ....J.D.

Check out mitsubishi-forums.com also.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #19 ·
No ive run down air leaks and wirring and checked injectors so im stumped. Im waiting on my tactrix ecuflash to arrive and see what ican learn fron it. My hope is that once i set things up for the new injectors it will smothe out if not im at a loss of what could cause the missfire on no 3.
 
1 - 20 of 20 Posts
Top