Mitsubishi Eclipse 3G Club banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys please help, im a college kid and my 03 eclipse is starting to have serious transmission issues. it only occurs after long drives of 75 miles or more (usually about an hr or 2 of driving. it is the 2.4 with the sportronic. it slips after getting off the highway mainly in the 3/4 change, however it occasionally does it during the 2/3 shift as well. Trans fluid is not bright pink but isnt brown either, kind of a darker pink, not burnt smelling. level is good. put Lucas in to try and fix it and it did help however the problem still remains, no CEL or Trans light. Should i attempt a fluid change, then change it again after a few weeks, or should i look into a reman transmission. also i read online about a service bulletin about a 2/3 transmission slip, is this related?
 

·
Sword at the Ready!
Joined
·
390 Posts
Sounds like the clutch packs for 3/4 are toast. But then again it might just be that flare as it occurs in both 2-3 and 3-4. Have you disconnected the battery recently for anything, as those "slips" occur for up to like two wks afterwards?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
After resetting the battery nothing changed, felt a little diffrent as the car was re-learning its shift points. ended up completely replacing the transmission at home for $200. now everything is fine and dandy! Shes got 212,000 miles and i hope to welcome her to 300,000. Thanks again!
 
1 - 5 of 5 Posts
Top