Mitsubishi Eclipse 3G Club banner
21 - 35 of 35 Posts

·
Registered
2005 Spyder GT
Joined
·
292 Posts
looked at the diagram. theres no fuse there :-(
give me your VIN# and I'll look it up on the Mitsu ASA parts database. I remember another thread where the member had a hard time finding the location of the relay, so it may be different by year, model, engine, etc.
 

·
Registered
2005 Spyder GT
Joined
·
292 Posts
its not a fuse, its a relay and looks like a little grey box. If you have an Auto trans, you might not have a starter relay, in which case I reccommend disconnecting and cleaning the connections at the starter with some sand paper.
 

·
Registered
2001 Spyder GT. Koni adjustable shocks. ST sway bar.17X8.5 rims. LED headlights.
Joined
·
140 Posts
I thought you were replacing the starter RELAY. It is a small black or grey plastic cube about 3/4" square. What fuse are you talking about ? ...J.D.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #28 ·
i know where the relay is....problem is there's no relay in the fuse box to begin with but the car starts up 4/5 times no. someday it starts up all the time. now a lean code popped up this morning (p0171)
and i cannot find the vacuum leak.......at least the car starts and drives now.
 

·
Registered
2001 Spyder GT. Koni adjustable shocks. ST sway bar.17X8.5 rims. LED headlights.
Joined
·
140 Posts
I think this guy is wasting our time. ...J.D.
 

·
Registered
2005 Spyder GT
Joined
·
292 Posts
i know where the relay is....problem is there's no relay in the fuse box to begin with but the car starts up 4/5 times no. someday it starts up all the time. now a lean code popped up this morning (p0171)
and i cannot find the vacuum leak.......at least the car starts and drives now.
You didn't say if your car is auto or manual trans, but I have read elsewhere that auto trans DOES NOT have a starter relay. So if auto, move on to next possible culprit, such as wire connections to starter, bad spot on starter, neutral safety switch, etc.
 

·
Super Moderator
2001 Spyder GT
Joined
·
840 Posts
This type of language is not allowed on this site. Your opinion of the person you speak of may be true but please refrain from voicing it in the public domain. What is said in a private message is between the two parties...... :);) This is not a warning...just a reminder to keep it clean in the open forum...Thank You
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #33 ·
Hey sorry working a lot, but it's an automatic. so it makes sense now why it doesn't have a relay.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #34 ·
Alright!!!!!!!!!!!!!! i found out what happened!!!!!!!!!!!!!!!!!! my friend did not put in the harmonic balancer after the timing job correctly. so the belts was slipping and caused my intermittent no start.
 
21 - 35 of 35 Posts
Top