Mitsubishi Eclipse 3G Club banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
okay, i have a 00 eclipse gt, ive had an after market head unit in it previously. i took it out to put it in something else and dropped and broke it in the process. long story short i bought a brand new cd player yesterday, went to hook it up, nothing. now my dash clock doesnt work. the whole thing wont light up and my moon roof is stuck open. thats right open! in ohio thats a bad thing. checked all fuses and they seem good, my car was also idling very low for a few hours afterwards. which is strange, it was around 3-400 rpms. which is wierd because it usually idles around 8-1100. i need help please if anyone has gone thru this! i have to atleast close my moon roof somehow so i can drive it. any tips or ideas are HIGHLY appreciated!!! thank you again
 

·
Autocrosser
Joined
·
36 Posts
Also, check under the dash and make sure nothing is loose. Push all connections to make sure they are tight. One day I accidentaly kicked the box that attaches behind the fuse box and the blinkers and half the accesories didn't work. Pushed it back together and it worked fine
 

·
Premium Member
Joined
·
126 Posts
the same thing happened to me last night (except the moon roof =p) radio, clock pod, dome light doesnt work anymore. i checked the radio fuse and dome light fuse and nothing. all thew wires look in pretty good shape. any ideas?
 

·
Registered
Joined
·
4 Posts
okay, i have a 00 eclipse gt, ive had an after market head unit in it previously. i took it out to put it in something else and dropped and broke it in the process. long story short i bought a brand new cd player yesterday, went to hook it up, nothing. now my dash clock doesnt work. the whole thing wont light up and my moon roof is stuck open. thats right open! in ohio thats a bad thing. checked all fuses and they seem good, my car was also idling very low for a few hours afterwards. which is strange, it was around 3-400 rpms. which is wierd because it usually idles around 8-1100. i need help please if anyone has gone thru this! i have to atleast close my moon roof somehow so i can drive it. any tips or ideas are HIGHLY appreciated!!! thank you again
Did U ever figure out issue with ur Eclipse. I know it's been yrs since post but I'm having same issue and hoping to figure it out.
 
1 - 10 of 10 Posts
Top