Mitsubishi Eclipse 3G Club banner
1 - 20 of 216 Posts

·
Kampfbereit
Joined
·
17,854 Posts
Discussion Starter · #1 ·
Has anyone installed the e-manage on a Sporty GT yet?

I'm having serious issues with my timing signal, and I'm doing my best to isolate it when I have time to look at it but right now it is just bypassing the e-manage right now.

What ends up happening is that when my timing wire is spliced into my e-manage, that the car runs rich (like its pulling timing a lot to begin with) to the point where I'll be driving my car and I push the gas pedal and I get nothing but backfire out of my exhaust. We followed the API instructions (despite they were missing a few key wires) and I'm beginning to wonder if it is a Sporty issue or not. I only say that because another guy here in Orlando had a shop that had a shop install an e-manage into his car and it didn't work right either for the timing side. I'm hoping there is some sort of oversight here.

Now that I'm sitting here thinking about it... I think Ryu has the E-Manage installed on his car which is the SDS suck through converted sporty.

I'm sure the Greybox guys would be having problems with this as well for the sporties.

Any ideas?
 

·
Registered
Joined
·
219 Posts
Make sure you upgrade the firmware to the latest on those things. There had been a couple of pretty important bug fixes in the updates. Also, keep in mind you've got some pretty beefy injectors. Note also that the e-manage starts at 0. 0 = stock map values. Make sure the proper injector size is entered in the emanage as well.

I was running extremely rich with my set up as well. Had to lean it out quite a bit for it to even idle properly.
 

·
Kampfbereit
Joined
·
17,854 Posts
Discussion Starter · #4 ·
EdLo said:
Make sure you upgrade the firmware to the latest on those things. There had been a couple of pretty important bug fixes in the updates. Also, keep in mind you've got some pretty beefy injectors. Note also that the e-manage starts at 0. 0 = stock map values. Make sure the proper injector size is entered in the emanage as well.

I was running extremely rich with my set up as well. Had to lean it out quite a bit for it to even idle properly.
When I have the timing bypassed, my car runs really well and I have a baseline tune from our kits already preloaded in my e-manage. I also did the firmware upgrade as well (although I can't think off the top of my head what version it is).
 

·
Kampfbereit
Joined
·
17,854 Posts
Discussion Starter · #5 ·
Wikid-3G said:
Donnie does'nt know how to tune a sporty using E-manage?
Please understand that the e-manage is programmed via a laptop computer. You can save the tunes and copy them just like regular files. I received a copy of Donny's base tune that goes out with the kits we sell. I for one, will say that it's an excellent tune.

Something else I forgot to add in all of this is that I had my AFC hooked up at the same time (just to get a digital read out of RPM & TPS (no correction wires were hooked up). I am going to go under my dash and cut that out completely then insure that all of my connections are good on the e-manage.

The purpose of this thread was just to see if anyone else has gotten a e-manage to work on a Sporty GT yet. Again I think Ryu's car is a sporty so I should be good to go. I just need to go back and recheck things underneath the dash.

I admittedly had someone else install my e-manage because I'm 6'3" and don't fit underneath the dash too well. I think maybe that's where I made my mistake, and I'm pretty mad at myself for it. Regardless, I did verify the timing wire was indeed correctly spliced though.
 

·
Registered
Joined
·
1,433 Posts
ALso if need be you can always lie to the emanage about injector size to lean it out some more. Sometimes the correction factor works better this way I dunno why.
 

·
Kampfbereit
Joined
·
17,854 Posts
Discussion Starter · #8 ·
DNS-EN said:
ALso if need be you can always lie to the emanage about injector size to lean it out some more. Sometimes the correction factor works better this way I dunno why.
You guys keep missing the point. Aside from the timing issue, the e-manage is wired in and working just fine. The injector #s, correction and additional fuel injection works just fine and the car hums right along beautifully.

When I put the e-manage in the loop it starts running super rich as if it's pulling a poop load of timing and the whole car just runs like booty. This, is what I am trying to rectify. Idealy with no timing modification set on the e-manage, there should be no change with the way my car functions with the timing wire spliced into the e-manage.
 

·
Evo IX
Joined
·
1,767 Posts
Tearstone said:
Hrmm.. definitely or there is something else I am missing.
Russ are you going to the bradenton track meet on the 21'st? If so you can take a peek under my dash and compare my connections to yours.
 

·
Kampfbereit
Joined
·
17,854 Posts
Discussion Starter · #18 ·
TheFranchise said:
also all i remember from the bb and afr installs was the Manuals use pin 43 and Autos Pin 45 for crank signal
Ooooohhhhhhh That's good information. I'm using the following pins:

I'm using these instructions from API. (Although the pin outs below do not say anything about TPS, I got the TPS wire from my AFC install)

The dipswith setting is 5,8,4

5 stands for 6cyl Distributor.
8,4 is MKII Karmon Vortex

Read the pins left to right, top to bottom. Consider the far left plug A, the next B and so on. All pins are from the wire side of the connector. The clip side is the top. Remember that even empty pins count.

Please do not make a post that the FSM does not state A,B,C,D. The FSM numbering is oddball. A is 1-35. B is 40-66. C is 71-98. D is 101-130. (This is for a A/T ECU) This factory numbering is easier to lose count so I renumbered my schematics for ease of use.

INJ 1...........................A1 YEL/BLU
INJ2............................A9 YEL/RED
INJ3............................A24 YEL/BLK
INJ4............................A2 GRN/YEL
INJ5............................A10 GRN/RED
INJ6............................A25 LT GRN
INJ GRND....................B6 M/T B2 A/T BLK
DISTRIBUTOR(t)..........A11 BLU/BLK
TPS.............................C8 YEL
AIRFLOW....................B21 M/T B25 A/T WHT/GRN
RPM............................B3 M/T B5 A/T WHT
GROUND.....................B18 M/T B8 A/T BLK
12V.............................C29 M/T C28 A/T BLK/WHT

The pinouts for A/T are the same for Sportronic or Non.
 

·
Kampfbereit
Joined
·
17,854 Posts
Discussion Starter · #20 ·
TheFranchise said:
also all i remember from the bb and afr installs was the Manuals use pin 43 and Autos Pin 45 for crank signal
On second thought... I think Donny was saying that you all do that. He said you all grab the signal from the crank, and API uses the signal from the ECU to the distributer :scratch:
 
1 - 20 of 216 Posts
Top