Mitsubishi Eclipse 3G Club banner
1 - 8 of 8 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
Ok, after searching around for the last couple of hours. I'm pretty sure this rattling sound is the tob, because it will completely stop and the engine will sound like a regular engine. The only thing that has recently bugging me is that this rattle seems like it's getting louder and also rattles when accelerating(is this a symptom of tob rattle?). I just really couldn't find anything about the continual rattling while accelerating.
 

·
King Shango
Joined
·
3,077 Posts
Ok, after searching around for the last couple of hours. I'm pretty sure this rattling sound is the tob, because it will completely stop and the engine will sound like a regular engine. The only thing that has recently bugging me is that this rattle seems like it's getting louder and also rattles when accelerating(is this a symptom of tob rattle?). I just really couldn't find anything about the continual rattling while accelerating.
Check your motor mounts they might be going bad
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #3 ·
I thought bad motor mounts involved vibration like symptoms? The sound that I'm experiencing sounds exactly the same when I'm idling, just a bit faster repitition.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #4 ·
Alright I know i have the tob rattle, but there is an annoying noise when accelerating and i can also hear it when downshifting. i know the tob rattle only occurs in neutral so this has to be a different problem. it sounds like a rattle type noise in the engine somewhere. i'm thinking something might be loose or something, but i can't pinpoint the noise due to it only happening when driving around. i need some help because it's really starting to annoy and scare me. the car shifts fine and drives fine tho.
 

·
Registered
Joined
·
111 Posts
I have two rattles right now...does it sound like skittles bouncing around at the front driver's side of the car?
 

·
Registered
Joined
·
110 Posts
Could also be the evap purge valve solenoid, on the passenger side of the intake plenum. You can feel it ticking. It will also stop ticking when you unplug it's wiring harness.
 
1 - 8 of 8 Posts
Top