Mitsubishi Eclipse 3G Club banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,080 Posts
Discussion Starter · #1 ·
Here's an odd problem I've never experienced before.

Now, i've searched already and didn't find anything? SO I figure I would go ahead and start a new thread.

Okay, so I'm running to work this morning, and pull off at a local Hess here and was going to grab a drink or whatever, pull up to the building, throw the car in park, turn the key and hop out of the car, and while I was stepping out of the car, it occured to me that it was still running


????


I was dumbfounded, holding the key, and the ignition was in the Off position, and the car was still running. So I just sit there for a few minutes and stare at it, hop outta the car, hop back in, put the key in and click it forward and try and turn it off again, same outcome. I try this for a good 5 minutes or so before finallly popping the hood and loosening up the positive cable. So I run inside and grab a G2, head back out pop the cables back on, start it up and eventually pull into my work parking lot, and very precautiously shut the lights off, turn the air off and turn the key back one click and then another, and it doesn't shut off!! .. and after about 3-4 seconds after having the key out the car finally shuts down.

Wtf?


This isn't really that big of a problem, it's more-so weird really, I just don't want to have to pop the cables to just shut off my car. Any insight? Thanks in advance...
 

·
Registered
Joined
·
2,080 Posts
Discussion Starter · #3 ·
No, everything ignition wise is completely stock. I was stunned at first thinking it was cool, and it never shut off so I got a bit frustrated.
 

·
Registered
Joined
·
2,080 Posts
Discussion Starter · #5 ·
You know, I don't actually know. It was in park and I hadn't even thought about it, I'm guessing it would still shift though as long as my foot is on the brake, but not certain.

I'm still dumbfounded and will have to do some more research on it after work :happysad:
 

·
Banned
Joined
·
18,282 Posts
It sounds like your ignition switch (specifically - the tumblers inside) is bad. What this means to summarize is, when you turn your key, its not actually grabbing the tumbler inside the steering column nto move the "switch" from one place to another (on, off, acces). Replacing that should do the trick, but will also require re-keying the car.

Just to verify, glance at the key itself. Is it completely worn down? If so - try a new key thats fresh cut and see if you still have the same problem. If the key is so worn where the teeth don't grab the tumbler, this will also cause the same problem (unable to rotate the switch).
 

·
Registered
Joined
·
2,080 Posts
Discussion Starter · #7 ·
The key seems to be in good condition, I'll take a cameraphone picture if needed, but the teeth seem to be just fine, doesn't look too worn down. And what's weird when I turn the key I could feel it catch, or atleast assumed it was catching. It's so odd, I mean, if this theory was true, then wouldn't it have a hard time starting up as well? Which it has never had a hard time starting, or turning the power on. Hmm.
 

·
Banned
Joined
·
18,282 Posts
Just for process of elimination, have another key cut. It'll cost all of $2 and have sharp edges and see if you still have a problem with it. :)
 

·
Registered
Joined
·
2,080 Posts
Discussion Starter · #9 ·
Yeah, i'm going to make my way towards Home Depot and have one copied here shortly, it's just bewildering this, as I've never had anything like this happen to any of my older cars... Good logic though, i'll definately keep it bumped and let you guys know what has happened.
 
1 - 10 of 10 Posts
Top