Mitsubishi Eclipse 3G Club banner

1 - 7 of 7 Posts

·
Funky Old Greenhorn
Joined
·
11 Posts
Discussion Starter #1
At least that is what I think is going on. I had a speed sensor go out and replaced. Actually 2 were replaced and now the computer is having trouble. After replacing two speed sensors I was told to drive it and the computer would work out the shifts and everything (it's a 03 Eclipse 2.4L with an AUTOMATIC Transmission) Well it bucks and snorts... cuts off and on and after 15 to 20 min. it gets a lot better. It starts to shift better and quits cutting out as long as I am gentle with the throttle while it it working it all out. Adventually it does just fine.
But the next time I get in it and start it I go thru the same problem all over. Any Ideas why?
 

·
Registered
Joined
·
465 Posts
What does the EGR and throttle body have to do with your trans speed sensors? Sounds like you used non-OEM speed sensors that aren't working correctly.
 

·
Funky Old Greenhorn
Joined
·
11 Posts
Discussion Starter #3 (Edited)
I meant to say.... the ECU. I will corret my mistake. What a DOPE. Thank You Murkrow.
So you think my cheapo sensors are possibly the problem?
 

·
Registered
Joined
·
465 Posts
I reread your main post. Why would you assume it's a trans issue and not an engine issue? Posting videos of what's happening is your best chance to have it diagnosed correctly.
 

·
Funky Old Greenhorn
Joined
·
11 Posts
Discussion Starter #5
I have been going by what my mechanic had told me. I replaced two speed sensors because the speedo quit working and the transmission would start off and not shift out of 2nd gear. Sfter reading articles and posts on club3G I came to the conclusion that the speed sensors were not working and I replaced 2 of them. That did not fix the problem. I took it to a shop and he removed the sensors and made sure they were ok and he found a blown fuse and replaced that. After he took it for a spin we found the speedo working again. He said that the computer would have to re-calibrate the throttle position. And sure enough when I drove it the engine would cut out if I gave it too much throttle. It would cut out for 2 to 10 seconds bepending on how i pushed on the throttle. If I eased back on the throttle it would run , As long as I did not give it a lot of throttle fast. If I drive it around town slowly excellerating it works its self out and gets better after 10 miles or so. It slowly begins to run better and shift correctly. I can then pull over and excellerate from a complete stop with the enging running great and it shifting thru gears BUT it will be in 2nd gear when I take off. If I turn the key off and restart it , it will actually start off in 1st gear like it should and run thru the gears correctly. So far now... if I go to it cold and start it up I have to go thru the whole issue again for 10 or more miles. The mechanic said it was learning the throttle position and gears needed and would keep that information and it should stop being a problem. But it does it all over again next time I drive it. I will watch my temp guage and see if it emproves only because it is warmed up or because of the miles and throttle use. I AM NOT A MECHANIC AT ALL. THE ELECTRONICS IN ALL NEW CARS IS WAY BEYOND MY ABILITIES. So I am not sure what to conclude. I will take your advice and make a video of what it is doing. That is GREAT ADVICE. Thank You Murkrow.
With the pandemic I have not been going anywhere so that in itself has slowed down my working thru this problem.
 

·
Funky Old Greenhorn
Joined
·
11 Posts
Discussion Starter #6
I also put new OEM plugs in it before I drove it the last time. Old plugs looked good but that was just to try something new. It starts up cold perfectly. I will make a video from a cold start and show what all it does.
 

·
Here for the drama
Joined
·
151 Posts
Tell your mechanic to plug in his diagnostic computer and check the fuel trims and throttle position sensor via live data. Also check for trouble codes then get back to us..
If you can’t understand his lingo then take some pics and post up when he says the problem rises on the screen.
 
1 - 7 of 7 Posts
Top