Mitsubishi Eclipse 3G Club banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
Hello, I have a 2003 eclipse GTS and lately I've been getting the brake and battery light flashing on together, and also the TCS and antilock lights. The lights kind of go on and off, seemingly at random, and usually go off when I slow down/stop the car. Other than the lights, everything seemed fine. Then yesterday, I noticed my temp gauge was super high when the dash lights were on and then dropped immediately back to mid-level when the lights went off. I've never seen a temp gauge fluctuate so fast and so wildly. Do you think this means a faulty gauge or possibly electrics? Also worth noting, I replaced the alt within the past year, and the first thing I did when this started happening was go to autozone and had battery and alt checked, which they said were fine. Anyone have any suggestions? Thanks in advance.

Update: I have now noticed that the temp gauge only shoots up when the TCL and antilock lights are on, but if it's only the battery and brake lights then it goes back to normal.
 

·
Sword at the Ready!
Joined
·
390 Posts
Check the ground at the alternator...When I replaced the timing belt once I didn't tighten the ground bolt (one under the red flap) and it cause some of those symptoms.
 

·
Moderator
Joined
·
54,471 Posts
under the red cover is a power cable,not ground. Pull off the negative battery cable before messing with it since if your wrench hits the car it'll arc really bad and pop the 120A fuse or burn the hell out of your hand.
 
1 - 3 of 3 Posts
Top