Mitsubishi Eclipse 3G Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
What now when Metra 70-7003 is not exactly working??

I am trying to install Pioneer Avic F500bt (with Amp nd-g500 ) on my 2002 Mitsubishi Eclipse Sypder GT. I bought Metra 70-7003 in hoping that it will take care of the wiring

But Metra 70-7003 does not match the ISO connector ND-G500 has.

Here is how ND-G500 ISO connector looks like



Here is how Metra 70-7003 looks like




I connect the Metra 70-7003 to my factory speakers. I need to connect Metra 70-7003'S 4 RCAs to Amp - the middle one / ISO Connector.

How should I do this? Is there any connectors I can get or I have to cut wires?
Also how should I connect the Amp to the Factory Radio?

Thanks a lot!
 

·
Moderator
Joined
·
31,369 Posts
The main connector should still hook up to the OEM harness.... Needed for Power, Ignition, Ground, ect. The RCAs should attach to the unit, inless you dont have RCAs coming off the back of the unit.

I guess I would need some better pictures, to acess the situation a bit better. I checked on the Pioneer site to try to get a better look at the manual, but I am unsure of a few things. :(

Does both males go into that ISO connector, or is it just set up in 3 different ways depending on the application?

http://www.pioneerelectronics.com/StaticFiles/Manuals/Car/ND-G500_OwnersManual0410.pdf

See page 4.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3 (Edited)
thanks for the reply

Thanks a lot for your answer.

There is no RCA connector at the back of AMP or Avic F500bt. The three connectors displayed above are all I have.

I guess the big ISO connector (female) should connect to factory harness (1 for power (input) and 1 for speakers (output) -- I need 2 connectors or I need to splice the wires to connect to Metra 70-7003 then to factory harness here). Is there any connector for this??


the 2 male connector should connect to OEM headunit's power (output) and speakers (input) (Not sure what I should do here - if there is no connector to buy how can i connect these 2 male connectors from the Amp to OEM headunit??)

Here is the picture of the back of OEM unit - sorry for the bad picture quality:



4 set of cables are connected from left to right: Radio, Power, Speakers and antenna.

There are 2 ports not used and i wonder will I able to use them or just ignore them?

Hope i didn't confuse you more. :happysad:
 

·
Moderator
Joined
·
31,369 Posts
Well, the one harness (your one male from the pioneer) looks like it conects to the Car's Audio outputs (the speakers), but it can't cause all the speakers are ran though that Din cable to the factory amp under the seat. You prob can connect the one connector to the only OEM female connector in the car, but you are only going to have your power, ground, ect.

To get sound you are either going to have to do a search and find a product that will change the Audio wires to RCAs (so as you can use the 70-7003)or you might have to splice...which will take some time and will be a pain in the ass. Have you ever thought of calling Parts Express and telling them what you have, and see if they have something that they could hook you up with? That is how I found the 70-7003, I wanted to change out the OEM unit and I called them. They are very helpfull and will sit with you till they can come up with some way to get what you need. :)
 

·
Moderator
Joined
·
31,369 Posts
The AVIC-F500 is a portable nav unit, why would you need the 70-7003 to hook it up?
:uh: I'm not even going to say what I'm thinking.



































































READ!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 
1 - 6 of 6 Posts
Top