Mitsubishi Eclipse 3G Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I recently Purchased a non-running 2003 Mitsubishi Eclipse GT. It has 192,000 miles on it and has never had a tune up. I need to replace some wiring and all of the fluids because it has been sitting for 2 years. A mechanic said the reason it doesn't run is that the crankshaft position sensor needs replaced. The car has full power, turns over and the fuel pump is at least running because you can hear it. The MAF sensor was replaced. Where should I start this project. Should I replace all the fluids and do a tune up before i buy any major parts? anything will help. Thnx.
 

·
Here for the drama
Joined
·
164 Posts
You are all over the place.
#1: What wiring needs to be repaired?
#2: How’s the timing belt/ compression look like?
#3: Why does your mechanic think you need a ckps? (crank position sensor)
#4: and most important; provide us with engine light codes.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
You are all over the place.
#1: What wiring needs to be repaired?
#2: How’s the timing belt/ compression look like?
#3: Why does your mechanic think you need a ckps? (crank position sensor)
#4: and most important; provide us with engine light codes.
Sorry it has taken so long to reply. I had coronavirus and then had a super busy time at work. I repaired the wires needing repaired and had it inspected to make sure it is good. I was wondering what could prevent an obd 2 reader from scanning. I used my scanner today but it wont read anything. Keeps turning on the not showing anything so I cant figure out my codes. Could it be a problem since the car wont run. Also what is the best way to check the timing belt and compression. Thnx
 

·
Registered
Joined
·
533 Posts
Sorry it has taken so long to reply. I had coronavirus and then had a super busy time at work. I repaired the wires needing repaired and had it inspected to make sure it is good. I was wondering what could prevent an obd 2 reader from scanning. I used my scanner today but it wont read anything. Keeps turning on the not showing anything so I cant figure out my codes. Could it be a problem since the car wont run. Also what is the best way to check the timing belt and compression. Thnx
Based on your lack of experience you should probably have a credible shop perform the repairs.
 
1 - 4 of 4 Posts
Top