Mitsubishi Eclipse 3G Club banner
1 - 4 of 4 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Changed plugs, gasket, coils, egv and still it bogs down. Checked to see if there was a vacuum leak and I honestly thought the coils that came today would solve it.
I just want my little get up and go car back. Any ideas? I'm not mechanic but I know the basics.
Automotive parking light Wheel Car Tire Vehicle
 

· Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Is it a 4 or a 6 ? Is the check engine light on ? ...J.D.
4 and check engine light is on. AutoZone guy said clean EGR valve and change plugs. Actually bought a new egr valve and changed plugs. Just changed out both coil packs. It's missing and when I put my foot on the accelerator it just wants to die.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #9 · (Edited)
update. So far I changed coil packs, wires, spark plugs, egr valve, fuel pressure regulator. Tonight I added some injector cleaner in the gas tank (seafoam)
Don't know where id go to get a pressure check. Oh and I cleaned MAF sensor. Put airflow and filter back together. Cleaned battery posts and tightened. I am bashing my head against the steering wheel which is annoying because my horn sounds like a clown car.
As of a young fella at O'Reileys... Misfire, gas circuit low, air temp sensor, air flow circuit lean, map sensor low, system lean. This was before the install of the fuel pressure regulator. So i guess I should see what it says on their machine tomorrow. Thanks guys for all your input. I'm an old guy but love this little car as it was the first car i sold in the US for mitsubishi in 2003 from England. So to have this group and forum is awesome. Always loved the 3g.
Wheel Tire Car Vehicle Automotive lighting
 
1 - 4 of 4 Posts
Top