Mitsubishi Eclipse 3G Club banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
anyone had any real tuning experience with this motor? i have a 2004 with a turbo kit and emanage ultimate. the problem i'm getting is that the factory ecu will NOT go out of closed loop even after 5 seconds at 7 psi. what that means is despite the amount of fuel i add with either the airflow adjustment or the additonal injector, the ecu is pulling it back out as quick as i can add it in. 14.7:1 air/fuel and boost do not make for lasting friends. this is the most likely reason for reading about so many engines blowing up. new subarus are this way too and they are factory boosted. however, after about 4500 rpm, they do finally switch to open loop and flood the engine with fuel taking it down to about 10:1 air/fuel. their timing would be setup for that though, so doing it here is not safe.

i'm wondering what others with dynos or extensive tuning with a wideband and obd 2 scanner have found. i did not take this car past 4500 rpm for safety.

this tune is on hold until i can find out more info. anyone?

tk
 

·
Registered
Joined
·
1,429 Posts
What are you using to determine that the ECU is still on closed loop? Are the 02 sensor voltages still cycling? Post up a log if you can.

For my I4, I have noticed that almost as soon as I hit WOT (throttle position at 100 percent) the 02 voltages will stop bouncing around indicating to me that open loop has been reached.

Edit: How big is your turbo? I can see too small of a turbo boosting at part throttle and while still in closed loop causing all sorts of tuning problems.
 

·
I'm out.
Joined
·
88 Posts
What size injectors are you using? It's possible you're hitting the top of the stock fuel map. That was my problem. I could add fuel in the air flow adjust map till the cows came home, it wouldn't matter, I had to hook up the injector harness and add pulsewidth to the injectors directly.

-John
'00 Eclipse GT Twin Turbo
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
i'm not watching o2 voltage feedback, i'm watching a/f on my dyno's wideband. when i input 20% more injector duration i immediately see a/f go to the 12s, then nearly as quick see it rise back to 14.7:1. that's closed loop. can do the same thing at 3000 rpm fixed and full throttle (dynapack works like an engine dyno, it's fully loading).

injectors are rc 310cc.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
a litte more info.
04 gt 5 speed. ddynopower.com turbo kit with rc 310cc injectors.
emanage ultimate with injectors wires cut so ultimate can +/- injector pulsewidth, distributor (ign) wire cut so can +/- timing, same for MAF sensor.
emanage is installed and functioning correctly. i can see changes as i make, them, the factory ecu just adapts to them.
 

·
Turbo Buick > you
Joined
·
1,336 Posts
Are you blowing through the MAF or do you have a suck through setup?
 

·
Lance Corporal
Joined
·
3,953 Posts
I would defiantly hook up a datalogger and see for sure if its switching to open loop or not. Like Chief's, mine switches to open as soon as I hit 100% throttle. Even at 90% though its still in closed.
 

·
I'm out.
Joined
·
88 Posts
What table are you making your +20% fuel changes in?? I would agree that you need to datalog the stock ECU so you can determine exactly what it's doing. Trying to tune without completely knowing what the stock ECU is doing is dangerous.

-John
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top