Mitsubishi Eclipse 3G Club banner
1 - 6 of 6 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
I was driving to work and my check engine light came on. These trouble codes came up.

PO420
Catalyst Efficiency below threshold (bank 1)
^
(This code was shown twice)



P0455
EVAP Emmission Control System Leak (LARGE)

Any help as to what I should do, or what these codes are specifically would be a great help! It is a 2000 GT. Charcoal canister, and catalytic converter was my guess, but I would like some more input before I go spending money.

Thanks
 

·
(b)org banugee
Joined
·
4,549 Posts
The evap code is usually the gas cap not being screwed down. Screw it down and erase the code. If it comes back, replace the gas cap, then screw it down and erase the code. If it STILL comes back, start worrying about the EVAP system.

The Cat code is usually thrown by guys with headers. Your best bet is to try the anti-fouler trick even if you have your stock cats in place. If yours is a calispec, it could be very difficult and expensive to replace the precat for bank1. Even if it's fed spec, the part would be expensive all by itself.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #4 ·
Thank you citm2000 for the help, Ill try that. So far it hasnt come back on after just erasing it. Its been about 50miles after reset.
 

·
BoomGoesTheDynaMitt
Joined
·
7,180 Posts
Thank you citm2000 for the help, Ill try that. So far it hasnt come back on after just erasing it. Its been about 50miles after reset.
Give it 100 miles or 2-4 restarts :( I've been battling a P0455 for a year now. Seems intermittent though. When ever it is going to come back (immediately) it will do so within 100mi (usually after I have accelerated hard and then let off the gas and just held throttle @ around 3.5K-4K RPM) OR after I have restarted the car 4 times.

FWIW, I have replaced my EVAP purge solenoid (engine bay) and both tightened & replaced the gas cap and I still get the code. Not sure what else to look at.... I need to dig into the FSM a bit I guess.

:edit: Looks like I need to look into replacing my Evap emissions ventilation solenoid (near gas tank) :(
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #6 ·
So far they havent come back and its probably been about 60-70miles. Hopefully it was just my fuel cap.
 
1 - 6 of 6 Posts
Top