Mitsubishi Eclipse 3G Club banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Ok, so this set of codes has finally drove me mad!!!

For starters:
2003 Eclipse GS, 2.4L 4-Cylinder with stock engine, no upgrades.

I bought the car back in April 2013. After about a month of driving it, the check engine light came on. Bam. P0420. Catalyst Efficiency Below Threshold. The fella at Autozone told me not to worry about it, so I took it harshly and forgot about it. After a week or so, the CEL disappeared. So naturally, I thought the AZ guy was right. Couple months later, P0421 now shows up. Again, it disappears. After the barrage of P0420/P0421 codes, I finally look into. My mechanic suggested I replace the O2 sensors. I did and the code disappeared for three months. In June 2014, it came back. This time, it never went away.

Now, if I go to erase the code, as soon as the CEL pops up, it alternates between P0420 and P0421. My dreaded emissions test is now due at the end of the month and there is no way they will let me go free with a converter code.

My question is, has my Cat truly gone bad or is it on it's way out?

Side notes:
-New O2 Sensors
-Tune up done February 2015
-No signs of a vacuum leak or exhaust leak.
-New IAC Valve installed 2-15.

Some help would be appreciated!
:)
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
I've tried that a couple times because my mechanic suggested it. Just last week I took a 40 mile drive through open country roads miles long and still no avail. I do feel like over time my car feels more bogged down than when I first bought it like it's taking more effort to speed up.
 
1 - 5 of 5 Posts
Top