Mitsubishi Eclipse 3G Club banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
:) hello everyone

i finally grew a pair of balls to actually start my first thread! so please take it easy on me guys lol (rookie here) i just really need help.

first off i have a 2000 2.4L manual GS Eclipse.
112k miles

I've been having this real annoying issue with my car! seems to make a popping/clunking noise (kinda feels like a joint popping... and sounds like two metals hitting each other) from the front driver side.
Every time i reverse my vehicle a little or a lot, then shift into 1st gear and give it a little gas (1500 -2200 rpm's) i hear the sound. It seems to happen right when the car moves a little forward then it'll jerks back (since i only tap the pedal).
Sounds like two metals hit when the car jerks back.(i don't feel anything in the steering wheel when it pops.... just could hear the sound)
it'll also happen (sometimes not all the times) when i am on the high way
and start to slow down for a red light, or traffic etc.. i start to down shift ether to first or second gear.... once the tranny puts the car into gear i'll hear the noise again(just one pop) but like i said that doesn't always duplicate the sound.my first example though always duplicates the sound.
I've been SoOoOoOoOoOoOoOoOoOO!!!! annoyed by the sound that I've basically changed the whole front suspension AND STILL HEAR IT:)facepalm::noplease: like i said my car drives smooth ( since I've changed everything in the front ) here's the list of things I've changed.


got the car @ 98k noise started @102k


back and passenger side motor mounts @100k
front and tranny mount @110k
strut assemblies(just the front, passenger and driver side ) @110k
cv axels (both side)@ 106k
tranny fluid [email protected] (GL3)
control arms(both sides) @ 107k
inner and outer tie rods (both side) @110k
CAR [email protected]
sway bar [email protected]
even put in new tires hoping it'll take the noise [email protected]

anyone have this similar situation going on?
please any advice would benefit me!
once again my first post please excuse any typo's, or grammer errors lol.
 

·
Registered
Joined
·
2 Posts
Try checking your end-links and tie rod end for tightness. i recommend if you still cant find loose parts, lifted on both front corners to get the opposite tire off of the ground slightly wiggle test the tire by hand side to side, when securely lifted, no excessive play in that, get a johnson-bar and as its lifted on one corner securely carefully wedge the bar under the tire at an angle and lift up making the suspension mimic compression like a bump. visually watch your lower A arm ball-joint as well as your strut nuts (to see if you may have forgotten to tighten them.. it happens..) also check the two large bolts securing the A arm at the body of the car one may be loose. also If you cant 'feel' the bump at your steering wheel it is likely an anchor to the vehicle and not the hub.

Best luck, man.
 

·
Registered
Joined
·
2 Posts
To be honest it sounds like your A arm is loose @the body or a bad cv axle or unbolted chassis to cv/driveaxle retainer. Ive polyeurathaned all mounts: trans, engine and suspension; rebuilt and powder coated the rear upper arms, and moog swapped EVERY component except the anti-roll/sway bar on a 2001 GS so id be a good one to troubleshoot it lol ;)
 

·
Moderator
Joined
·
54,430 Posts
Could be a weak control arm, weak lower ball joint, weak inner or outer tierod, etc. Try to have someone put a hand on the suspension members with the wheels off the ground. Foot on the brake just gently dip into the clutch in first gear to try to load the engine and make it clunk or shift.
 

·
Registered
Joined
·
2 Posts
Hey i seen your post about the popping and clunking i have a gst thats doing the same thing also ive checked mounts and all but havent found out what it could be any luck?
 

·
Registered
Joined
·
2 Posts
most likely either your suspension or the cv axle
So im not sure but i think its caused from the middle runner it looks to me that maybe the person before me just put whatever on and didnt even center that bar ill upload pictures soon.
 
1 - 11 of 11 Posts
Top