Mitsubishi Eclipse 3G Club banner

1 - 5 of 5 Posts

·
Cola
Joined
·
766 Posts
Discussion Starter #1
Well I just had all of my belts replaced on the car, along with the water pump. But when I got it back, it sounds like.. I'm leaking air or something when the rpms are in the higher range.

It almost sounds like a turbo's spool, and happens around 3.5k rpm and up..

It makes the sound while I'm driving, and if I just rev it in neutral I can hear it. I'm not sure what it is, I searched.. only thing I could think of for searching was like.. air leaking.. or something.. so ya.. any help would be much appreciated..

2001 mt gt 86k miles.
 

·
BoomGoesTheDynaMitt
Joined
·
7,180 Posts
no SES light/code?
do you have an aftermarket air intake? if not does the stock air intake "scoop" still have the rivets installed that keep it from lifting up and hitting the hood?
any loss in power?
 

·
Cola
Joined
·
766 Posts
Discussion Starter #3
OH! wow sorry I completely forgot.

I do have CAI

it is NOT the extra deeper sound that you get from the intake nor is it the whistle from it.

i only noticed this noise after I had all my belts replaced.
 

·
Registered
Joined
·
358 Posts
If they used a serpentine belt with a diagonal crosscut in the ribs as a stress relief, it will whine like a roots supercharger. Its not all that bad though. It certainly makes people wonder just what is under the hood.............

If memory serves me right....... Goodyear belts have those crosscuts
 

·
Cola
Joined
·
766 Posts
Discussion Starter #5
Hardline-

Thanks for your info. I believe that has answered my question.

I was maybe thinking that.. since you have to use a tensioner for that T belt, Maybe.. its just making the noise because of how tight it is right now, and it hasnt completely settled into the car just yet.
 
1 - 5 of 5 Posts
Top