Mitsubishi Eclipse 3G Club banner
1 - 3 of 3 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
Sup guys, wondering if anyone here can help me out. i tried transfering a ingalls torque damper from my 2000 eclipse gt auto to my 2001 eclipse gt manual. when i took out the damper from my 2000 eclipse auto and tried putting back the nuts on the bolts of the engine mount i noticed the nuts wouldn't go back down all the way. so i went to the 2001 eclipse and noticed the bolts from the engine mount weren't sticking out as much as the ones in the 2000 eclipse. so i'm like "fuck". so i decided to put the damper back on the 2000 eclipse auto. but when i tried to unscrew the nuts from the bolts on the engine mount i noticed the nut and bolt were moving at the same time. now the bolt is a little loose when it's supposed to sit there securely from the engine mount. anyone have any idea how to fix this problem?? sorry for the long post but trying to be as descriptive at the same time keep it as simple as possible. thanks in advance for any feedback give.
mark
 

·
BoomGoesTheDynaMitt
Joined
·
7,180 Posts
Search. I had the same issue when 1st installing my Ingalls ETD. I'm pretty sure I posted pics and stuff. I had no real problems getting the mount's studs screwd back in place properly. You may want to use some locktite on them to keep them from coming out the next time you go to loosen those mounting nuts.

I think I had posted up my problem under Parts Reviews or Group Buys. The thread was specifically about the Ingalls ETD.
 
1 - 3 of 3 Posts
Top