Mitsubishi Eclipse 3G Club banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Okay - So I drive an '03 GTS with about 70,000 miles on it - about a week ago I noticed my car making weird vibrations while idling and my temperature gauge would go up. Now when I would begin to move my gauge would fall back into normal range but then would go back up when the engine would idle. Also, I think the Idle speed is a little lower than normal at about 600rpm as opposed to what I've normally seen at 7-800rpm. My fans appear to be working, and I don't see any leaks and since the temperature goes back to normal when not moving I assume the radiator is working fine. I hear there can be electrical problems in Mitsu cars? IDK. ANy suggestions?

Thanks :D

-bry
 

·
Premium Member
Joined
·
1,996 Posts
Vibrations- the vibrations could be from worn motor mounts. Check all 4

Temp gauge- the gauge falls back down when you're moving because air rushes through the radiator and cools it. The thermostat could be broken. Also check to see that you have enough coolant in your radiator not just the reservoir tank. I would recommend doing a pressure test to ensure there is no leakage in the radiator or engine. Coolant could leak from the engine and you wouldn't even notice

Idle speed- maybe clean the MAF with electronic cleaner? Cant tell you much more on this than that
 

·
R.i.p Silverside
Joined
·
1,302 Posts
Okay - So I drive an '03 GTS with about 70,000 miles on it - about a week ago I noticed my car making weird vibrations while idling and my temperature gauge would go up. Now when I would begin to move my gauge would fall back into normal range but then would go back up when the engine would idle. Also, I think the Idle speed is a little lower than normal at about 600rpm as opposed to what I've normally seen at 7-800rpm. My fans appear to be working, and I don't see any leaks and since the temperature goes back to normal when not moving I assume the radiator is working fine. I hear there can be electrical problems in Mitsu cars? IDK. ANy suggestions?

Thanks :D

-bry
What electrical problems, a little more specific please? Have you even bothered checking the basics? Are all your lines plugged in? Are you good on coolant? Have you done any mods? We need more information! Not to mention there are multiple threads that have been started regarding something like this, you're not the first person to have their car overheat.
 
1 - 4 of 4 Posts
Top