Mitsubishi Eclipse 3G Club banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi, Today when I turn on the lights of my car (Eclipse 2000 GT) the parking lights and the gauges didn't turn on only the low lights, I already checked the fuse and relay for the parking lights but they are fine!
Any ideas??? :mecry2:
 

·
Smart Ass
Joined
·
2,526 Posts
Hi, Today when I turn on the lights of my car (Eclipse 2000 GT) the parking lights and the gauges didn't turn on only the low lights, I already checked the fuse and relay for the parking lights but they are fine!
Any ideas??? :mecry2:
did you check the fuses in the yellow holder?
 

·
Registered
Joined
·
463 Posts
did you have someone unplug the wiring harness? i had a guy do this to me in high school just being a jackass, lol i almost got a ticket for it until i got a screwdriver out in front of the cop and pulled out the parking light to find that it was unplugged. i night shaded the turn signals, so the cop thought that the light wasn't shining though.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
did you check the fuses in the yellow holder?
I only checked the fuses under the wheel and in the fuse box, which are those fuses in the yellow holder?

In the fuse box are a little white box that I can't open it, it's that the yellow holder?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Someone told me that the "white box" showed in that pic is the front ECU and this could be my problem :S is that true? does it have a repair or I have to buy a new one?
 
1 - 8 of 8 Posts
Top